Homatics Box R 4K Plus

Yes, I’ve done this. I’ve tried through samba, and tried doing it in linux. It just does not work.

Dev said code was fairly similar in 5.4 kernel. I’m not sure about timeline.

Are you sure you copied the remote config to the correct location?

I don’t know how much You know about these devices or how to add files. Maybe this video will help.

I am. And just to be sure I put it in 12 other places. Not really, but I put it in the root as well. I ordered the flirc remote with the dongle so this will all be moot when it comes.

I very wise decision. IR does have his limitations.

I have a nokia 8010 running on 6261. I applied these remote keymaps but when I press the power button the device powers down (as expected). Pressing the power button again the device does not power back on. Unplugging it is needed. It suppose to just work with a IR remote?

Thank you

First off, thanks to the devs for an awesome project and the posts in this forum which have gotten me mostly up and running.

CoreELEC (official): 21.0-Omega_nightly_20240331 (Amlogic-ne.aarch64)
      Machine model: Dune/Homatics R 4K Plus
     CoreELEC dt-id: sc2_s905x4_sei_smb_280_id5
      Amlogic dt-id: sc2_s905x4_ah212-id5

I’m trying to get full-time Player-Led LLDV working and just can’t seem to get it. I’ve copied dovi.ko over to /storage from the local hardware, turned player-led on, forced 12-bit color depth and 4:2:2, but HDR10 content is still coming through as HDR10 instead of LLDV. Is this expected behavior? My DV native content works perfectly fine.

I’m really wanting player-led as I have an EZCOO SP12H2 with a patched EDID firmware that works around a BT2020 cyan push issue on my Epson LS12000 projector. That same device is enabling player-led LLDV on my Apple TV 4K no problem, but I’d like the same as well on my Dune box so my HDR10 content doesn’t look like crap at BT709.

Any assistance would be much appreciated.

you do not need to force it to 12 bit and 4.2.2
just leave it to auto settings and just enable player led you will see that the output is correct for hdr10 and DV as for hdr10.
Why because if you force it then you get wrong results
For example, hdr10 uses YCbCr 4.4.4 in and will display it in 12bits.
DV uses 4.2.2 10 Bits + 2 Bits for the RPU data that’s why you cannot change or force it.
If you force it to 12 bits than it will add extra 2 Bits and if your screen or projector can’t handle it will be resulting in a black screen
The Dovi.ko is only needed for playing FEL content and for what i’‘m reading current soc’'s of homatics don’t support it only the 922j socs.
But if it works For FEL on Homatics I like to hear it.

Thanks for your reply. Unfortunately this didn’t work but perhaps I wasn’t completely clear. I am trying to get the Homatics box to output LLDV all the time, even when it doesn’t have a DV source. For example, HDR10 content would be converted/mapped to LLDV on the player-side and my receiver/projector would see a Dolby Vision signal instead of an HDR10 signal. I don’t care about the color space as I have a solution for that. My Apple TV 4K (and according to AVS Forums several other devices) works with this EZCOO SP12H2 hack no problem so I’m hoping to replicate this on the Homatics box as well.

Hi all,

I’d like to express my gratitude and respect for all the work you folks put into this project. Saying that it is impressive is a huge understatement, congratulations.

I’ve been carefully reading this topic for about a month and several weeks ago I purchased a DuneHD Box R 4K, did the first boot on AndroidTV and it did a firmware update (6261 according to /android/odm/etc/build.prop). I did not complete the process with a Google Account and upon the Signup screen, I used the remote to restart/shutdown the box to boot CE, the true purposed use of this box. My CE use is purely of local content via a NAS system.

Running 20.5-Nexus, Amlogic-ne.aarch64, connected directly to a Panasonic OLED LZ1500, I have all I dream of! I tested lots of MKV/MP4 files HDR10 PQ and HLG, HDR10+ profile A and B. Of course DolbyVision profiles 5L3, 5L6, 5L9, 8L6, 8L10, 8L12 and of course 7L3 and 7L6 FEL. Everything works fine as expected with 7L6 being converted to 8L1 as recommended.

I’m in the process of acquiring an AVR to put in between the box and the TV. A friend was kind enough to lend me a Onkyo TX-NR5100 to do some tests and mainly see if it would impair the use of all the HDR modes but everything went fine and matched the results of the TV directly connected.

Generic information that might (or not :slight_smile:) help other users :

  1. Idle temperature ~50°C on both the default skin and AeonNOX:SiLVO
  2. Playing the first Lord of the rings 4K movie (DV7L6), disabling amcodec acceleration and decoded Dolby TrueHD audio (no bitstream) was my kind of stress test as this is an overall of ~71 Mbps MKV file. Temperature reached 72°C and stayed constant. Movie was horrible to watch but this was a test, not a movie session and I wasn’t in front of it, just monitoring temps via SSH on my desktop.
  3. iperf measured ~933 Mbps which is expected

There are very small issues and I don’t really care about but for the sake of being thorough, here they are :

  • VP9 SDR 1080p files work fine but any VP9 4K HDR I have behave really badly. I see the Kodi spinner upon start and after a while, pressing x on keyboard (STOP) stops but freezes the GUI. HTop show Kodi at 100% CPU and killing it is not possible (SIGTERM as well as SIGKILL). I have to physically disconnect the power and put it back again.

Clips examples : I download them with YT-DLP and use the MKV container

  1. Dolby - Kingdom of colors : https://www.youtube.com/watch?v=uH_-N2ks8Wc
  2. LG - Chess : https://www.youtube.com/watch?v=2RIDhA9c8qw
    and I have several others.


yt-dlp -f 140+337 --merge-output-format mkv YT_URL

As said, I don’t really care as they are mainly demo files to test on systems I come across but maybe the developers are interested in testing and finding why this happens.

Sorry for the very long post but again, I wanted to express my deep gratitude and huge respect to all the people involved in CoreELEC, this is amazing, truly!

1 Like


I currently own an old AVR which does not know about HDR. Until I get a new one, I wanted to test the EZCOO SP12H2 to passthrough DuneHD Box R 4K to the TV as-is and the secondary HDMI to the AVR for the MultiChannel Audio part.

It did not go well at all… HDR10 HLG did not work anymore which indicates that EZCOO uses HDMI 2.0 instead of 2.0b which is required for HLG.

DolbyVision was transmitted as LLDV no matter what the source file was, whatever DV profile and level.

The worst of all, the AVR did not receive any sound, which was the main reason I ordered the EZCOO in the first place. No combination of DIP switches gave any satisfactory result and I had to return the EZCOO splitter.

I don’t doubt this is an excellent HDMI splitter but for my use case and given that the TV can confirm/infirm via its info panel what CE is sending, I clearly see that there are some conversions/changes with the EZCOO in between.

Maybe the modernized version is better - https://www.easycoolav.com/products/4k-120hz-hdmi-21-splitter-8k-60hz-1-in2-out-vrr-allm - but the price tag is too high for my simple use case.

I couldn’t find what I’m really searching for : A simple splitter which passes INPUT HDMI to OUT-1 HDMI video 1:1 with audio silence and to OUT-2 HDMI with no video and audio 1:1 as received. A true HDMI Audio/Video splitter.

It’s not a maybe, that EZ-SP12H21 works for me with what you are describing. I use it for a slightly different reason then you do, but the setup is the same.

Were you using stock firmware on the SP12H2 or did you flash one that spoofs the EDID? There’s a lot of good information on this repo (and it’s where I’m getting the firmware specific to my Epson LS12000 right now).

Does your HDR10 content output as LLDV or HDR10? Would you mind sharing your Video and Dolby Vision settings in CoreELEC?

I did know about the firmware repo. It didn’t even cross my mind that such a repo could exist, this is very nice :slight_smile:

I can’t test anymore though as I returned the splitter a few days ago.

Note The repo readme states Disables display-led DV which is weird or maybe I’m missing something here. Isn’t that supposed to be like TV-led? If it’s disabled, the only option left is Player-led and owning a TV which can handle every single HDR mode there is, this is not really satisfactory in my book.

Adding a bit more info, in case it could be of any interest to the developers.

Related to post 225 by @Portisch : Panasonic LZ1500E

$ cat /sys/class/amhdmitx/amhdmitx0/dv_cap

DolbyVision RX support list:
VSVDB Version: V2
2160p60hz: 1
Support mode:
IEEEOUI: 0x00d046
EMP: 0
VSVDB: eb0146d0004d037a885c6d95

Note With the Onkyo TX-NR5100 between the DuneHD Box R 4k and the TV, the output was exactly the same and as stated before, I had no difference in behavior.

Related to post 242 by @Portisch :

$ cat /sys/module/aml_media/parameters/dolby_vision_flags

I tried 16389 as in the post but I couldn’t see/detect any difference.

Hey guys. I have 2 questions:

  1. How do I update to the stable 21-omega version? (Currently running nightly build and have auto-updates on with “update to the next stable”).
  2. What settings do you recommend to use with DV? Player-led or TV-led? I am bit confused what is better for streaming DV. (TV - LG G3).

Thank you.


1 Like

Hi folks,

Is Wake on LAN supposed to work universally or does it depend on the device? I’m testing the Suspend feature and so far so good both on USB2 and USB3. I use my TV remote and via CEC, switching the TV to the HDMI connected to the DuneHD Box R wakes it up and everything works fine afterwards without lockups and freezes.

But, now the device is connected to a classic PC monitor at my desk, which obviously does not speak CEC at all, and I’m stuck trying to wake it after suspend. No joy through keyboard/mouse of course as the USB ports are powered off.

From my Linux desktop, using both wakeonlan and etherwake does not lead to a wake up. Any clues?

Does it requires a specially crafted packet to make WOL work properly?

WOL is only supported if a RTL8211F ETH phy is assembled, and then not always as the bootloader must support it as well.