Homatics Box R 4K Plus




It Works now. Currently updating. Thank you!!!

After all, it turns out it was a non issue about the USB sticks not working properly.

Hi again :slight_smile:

On another matter : Audio

I’ve tested the DuneHD with my old AVR on the Audio side this time and everything works fine except one small caveat.

Stereo and MultiChannel FLAC files I have for my tests work fine. I don’t use Passthrough obviously for these files, so pure PCM is sent over HDMI. My AVR reports the received channels either with the front display, via on screen status display and on screen Information page and 2.0, 5.1 and 7.1 matches perfectly with the source, meaning channels number and sampling frequency.

But, every 4.0 (ie: “quad”, L R Ls Rs) is sent as 5.1 to the AVR as confirmed by every info screen available. Every channel placement is handled correctly with the correct sampling frequency (48/96/192 KHz), there’s just this “phantom” muted center channel, or more precisely, silence data. The same goes for the “phantom” LFE channel, pure silence of course.

NOTE: There’s no difference between “HDMI” and “Multi CH HDMI” for the audio output.

Is this expected, a limitation of the Amlogic SoC or something else? This poses no issue per se but seems a bit weird.

LibreELEC on an old x86 NUC with the same source correctly sends 4 channels with a “quad” (L R Ls Rs) layout to the AVR.

Hi @p750mmx ,

Your message convinced me to give it a try and I ordered the EZ-SP12H21. Unfortunately, it did not gave the results I was expecting. Yes, this time the AVR got the audio from OUT-2 and I had to tweak things a bit. Also, HDR10+ and HLG now work properly because of the HDMI 2.1 in the EZ dongle.

My main complain is of course DolbyVision, which is now exclusively sent as 12 bit 444 in DV-LL format. This is confirmed by CoreELEC info panel (o key) and with the info from here :

$ cat /sys/class/amhdmitx/amhdmitx0/dv_cap
DolbyVision RX support list:
VSVDB Version: V2
2160p60hz: 1
Support mode:
IEEEOUI: 0x00d046
EMP: 0
VSVDB: eb0146d000450b908660768f

Instead of the direct TV connection which gives :

$ cat /sys/class/amhdmitx/amhdmitx0/dv_cap

DolbyVision RX support list:
VSVDB Version: V2
2160p60hz: 1
Support mode:
IEEEOUI: 0x00d046
EMP: 0
VSVDB: eb0146d0004d037a885c6d95

At least I tried and thank you for the suggestion.

Over @ avsforum there is a guide to load custom fw and make your own edid for Ezcoo.
I have loaded a cfw for my Epson ls 12000 projector with lldv 4:2:2

I know, it was already mentioned by kdelaney in post 2327 but I’m not interested at all in DVLL. I have a high end TV which handles DV perfectly, there’s no way I turn to cheaper solutions :slight_smile:

And “cheaper” must be taken with a grain of salt as the EZ-12H21 is not what I would call cheap :sweat_smile:

Portisch said it very clearly in another topic post

RGB is preferred over LL to have full colour band witdh

How do you confirm that RGB is used for DV? Is it enough to see the “pixel format: RGB…” in the kodi info screen?

Yes, that’s enough. If your TV supports it, you can also confirm using extended information in the “Info panel” or whatever it is called in various TV brands.

If you happen to have a modern AVR between CE and your TV, it can also give some useful information. I’ve tested with a Onkyo and it reported all display modes in the on-screen info panel triggered by the “Info” button on the front of the AVR.

Im having local lan transfer speed limited to 100Mbit on my Dune HD. This issue started after RC1 or 2 not sure but it exists on the final Omega release aswell. I can reboot the box and i get 1Gig again but most of the time on the first boot it goes back to 100Mbit with transfer speeds limited around 11Mbps as compare to 115Mbps when 1Gig is recognized. Any idea if the box is initiating wrong Ethernet driver. Can someone with Dune HD variant let me know if you’re experiencing this issue? TIA

There is another phy used in these boxes so they don’t have fixes like we did for the Realtek once.
We can put it on todo list.

1 Like

I have a homatics for sale (UK) if anyone is interested before I put it on Ebay.

I could not foresee the DV part, as in, my “Old” 4k Oled only supports HDR10, nothing else. Sorry :smiling_face_with_tear:

Hello all, I have Nokia 8010 (v12.8.3638 with 5.4.242 kernel)

My current issues are:

  1. The crop issue on FHD/HD H264 content you’ve solved - is it now available in the latest nightly build for NE? Both 20/21?

  2. Ethernet is not working under ELEC, I can’t find where this was discussed specifically for Nokia/S905X4-K. I’ve tried both 20.5 (Stable/Nightly) and 21 builds from around 5 April. Was this ever solved too?

  3. Remote - I have the “new” V2 model (RC212) I’ve tried to make it work using IR on ELEC, I followed the forum guide and used the existing keymaps but nothing seems to be working.
    I followed this guide using SSH per this post.
    All the codes except one (the bottom “Blue” quick-nav) ended with:

’ not recognised, no mapping for scancode 0x041d022e

Can it be because of the V2, so I should follow the extended guide to “catch” codes one by one using remote to create my own custom keymap?

Thanks for info and all the work you constantly do =)

This seems to have it fixed 100Mbit issue on Dune HD

ethtool -s eth0 speed 1000 duplex full autoneg of f” placed it into “autostart.sh

Im now getting 1gig on each cold boot, hopefully it will stay this way.


No need to apologize, you suggested a possible solution which is the very essence of this forum, helping users :smile:

1 Like


It seems no answer nor clue where to look will ever come out for this issue so I won’t waste any valuable resource or anyone’s time. To avoid cluttering an already quite long thread, the post will be deleted.

Well for me ethernet worked half the time. Often I had to reboot to get it to work again.
Never got the remote to work even with all the guides from this site.
Also had HDMI handshake issues with audio where there was no audio until a reboot.

Luckily I got the Nokia off Amazon and I returned it as it was just too frustrating an experience. Maybe it will get sorted in the future.

Good afternoon everyone, I’m thinking about buying a homatics 4k r plus with the u sb tuner dvb s2, I can install coreelec, the tvheadend detects the tuner, thank you for your help