Homatics game controller sending unwanted signals

I recently bought this gamepad to use with my Homatics Dune HD box. I am using it for gaming in both Android and CoreElec. Currently more often in CE via RetroArch and uae4arm when emulating Commodore Amiga games.
I have noticed that after some time of playing, controller starts to send unwanted signals. That is fortunately not doing in games itself, but rather if I escape from it and I am back either in UAE settings or back in Kodi. It’s not entirely possible to navigate through menus or change anything with the gamepad. If I try something via standard Homatics B25 controller, I think gamepad is disturbing it, so solution is to turn gamepad off. Then all is back to normal. I tried to remove batteries from B25 remote controller so that only one remote is paired, but that doesn’t change anything.
It is annoying mainly when you want to go out of the game and change something within UAE.
I am wondering, whether the controller itself might be faulty or if that is software incompatibility of some kind? I believe I experienced similar behavior in Android too, but this happened very rarely. In CE it happens almost always.
I tried and look for Homatics game controller in the list of controllers in Kodi. I am not surprised it’s not there, so I am using standard Kodi gamepad as a “driver”.
Would adding this controller into the list in Kodi help? Is it sensible to kindly request this or is this rather Kodi development team that is capable of doing that rather than guys who drives the CE project?
In case my limited knowledge may help, I am ready to assist in this task in case any info would be needed.

This is the gamepad I am referring to:

Thank you.

I have feedback this is in fact happening on some controllers where joysticks send micro signals or micro movements. it might be possible to filter this somehow in windows or better say, to set a threshold where this is ignored, which it apparently not in Kodi.
seems my controller is not faulty, but difficult to use it under some circumstances.
I would be curious if anybody found a way how to workaround this except switching gamepad off and back on.

Ive had smilar issues with Xiaomi Gamepad Controller.
Is also Bluetooth.

Once you stop Gameplay
Exit addon.

System seems to revert to Kodi default controller config.(which is based on Xbox 360 controller).

To navigate ui i use generic ir remote
Work around
But not solution.

well yes, in Kodi, I can simply turn off gamepad and use standard remote.
Amiga games I am emulating under Kodi usually use only a few basic keys that are working fine. But when playing in Android, these new games are using all the keys, including L1, L2, etc. these are doing mess.
So currently playing Deliver Us The Moon, where R2 brings specific discovery game mode. Gamepad is sending many short signals on R2 key, so it is constantly entering and exiting that mode, which makes the game unplayable.
I don’t understand how such gamepad can be sold. Homatics brand, used with Homatics box on Homatics Android. Right, I am using Blacknut, which is game streaming platform, but I would bet this would behave the same way on locally installed game.

There a multiple ways to navigate Kodi/CoreELEC

Have even used Kore app on mobile devices

On main machine in Family Room

I alway use Logitech K 400+ wireless keyboard

Then when i game
Turn on Xiaomi gamepad

To each his own method of madness!!!

Happy Testing

Well, I bought new controller. Logitech F710. This one is working without any issues and as expected both in Android and CE, so I suspect the Homatics gamepad was faulty.
I wouldn’t recommend it. Both joysticks are from poor material.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.