Horizontal shift displaying live TV


#1

I am running CoreELEC on two Amlogic boxes with two more arriving shortly. One box is an OSMC Vero4k, and the other a generic S905W (X96).

When watching live TV, I regularly observe the image shifting horizontally by a few pixels. The image often jumps back and forth a few times, which is particularly distracting. The issue doesn’t seem to occur with pre-recorded content or when live TV is paused (I may need to observe for longer to confirm), but it does also occur when playing live TV which has previously been paused.

The shift occurs only with the video, not the GUI overlay. The same issue appears on both boxes/TVs.

Can anyone suggest what might be causing this and ideally offer a solution?

CoreELEC 9.0.1, Tvheadend 4.2.8.


#2

I have the same problem. TVbox on s905x CPU, CoreELEC 9.0 nightly, Tvheadend 4.3-1774.


#3

I have the same issue on 1080i content.
It looks like amlogic deinterlace+processing issue.
As not so good solution you can disable deinterlacing. It occurs most time on static part of 1080i stream.


#4

Disabling deinterlacing appears to have worked. I agree, not a great solution. The boxes are primarily used for live TV, so hopefully there will be a fix one day.


#5

Same here.
Indeed disabling deinterlacing is a valid workaround, but as i also use CE mainly for livetv i hope this gets some special attention :wink:

I really like the quality of every release very much though; i think its amazing what has already been accomplished and i cant find much flaws otherwise.