Horrible crackling on music S905x

Hi guys,

I’ve been having this issue for quite some time now but was always loathe to tackle it since it is so hard to troubleshoot. When playing music, most of all high-res (24bit) multi-channel audio the music is sometimes but not always accompanied by horrible crackling/distortion. Moreover, any keypress from the IR remote is then also heard as additional crackling. When I stop playback and start it again, crackling may or may not return on next playback… I haven’t found a pattern. I’ve tried all combinations of settings I can think of in Kodi to no avail. It almost feels as if the CPU is not powerful enough to handle the audio when background processes run but that’s just a guess.

Here’s a log while crackling is happening.
Here’s a demo file (big) to test but remember it doesn’t happen every time - you may have to restart it several times.

I think this started with the 9-series of CE, but not really sure. Any ideas?

No downloads, no reply… everybody must be on holidays.

No crackling here. Remote keypress makes no audible effect.
The record is not my favourite so I just listened twice.
But never experienced any crackling with my 24 bit music.

No crackling here neither on my Mecool M8S PRO+… How many times do you need to play the sample for it to happen? 5? 25?

Have you tried to turn off GUI sounds completely?

Coming back to this I realized that it must be something in my setup because nobody else is complaining. I checked again and now noticed that the crackling only comes from the rear channels. It must be due to the “Stereo upmix” feature which I regularly use for stereo sources (and which automatically deactivates for multi-channel, or so I thought, because it crackles with quad sources, too).

Anyway, could you keep “Stereo upmix” under settings/system/audio activated and see if you can reproduce this behaviour at some point? Thanks again for your patience!

Why would you want to enable “Stereo upmix” i Kodi? I assume you are an audiophil since you are using hi-res audio, so you probably have an expensive AVR, right? If so, disable features such as “Stereo upmix” since you want to send audio as close to source as possible to your AVR which should do the heavy lifting

“Why” is not up to debate in this topic.

I’ve just tested with several 96 kHz and 192 kHz 24 bit music files (including your Santana track) and ‘stereo upmix’ feature doesn’t make any problem in audio here.

I’ve been trying different settings and configs and crackling indeed only happens with “stereo upmix” enabled, but not always. It usually starts after playing a few high-resolution files then stops and maybe starts again later. When a song crackles this persists throughout its whole duration.

I’ve found similar reports in relation to pulse audio (even though I use HDMI/Alsa) here:
https://kodi.wiki/view/PulseAudio#Known_issues

Adding or removing tsched=0 doesn’t seem to make much of a difference although crackling may appear less often and/or less pronounced when the parameter is present.