How to configure VFD

No, the Beelink GTKing Pro doesn’t have a display.

Here is the information requested for my HK1 RBOX S905X4 with no VFD

 cat /sys/kernel/debug/gpio
gpiochip0: GPIOs 425-511, parent: platform/pinctrl@0xfe004000, periphs-banks:
 gpio-439 (                    |amlsd               ) out hi
 gpio-449 (                    |amlsd               ) in  lo
 gpio-456 (                    |amlsd               ) out lo
 gpio-457 (                    |key                 ) in  hi
 gpio-465 (                    |?                   ) out hi
 gpio-471 (                    |avout_mute          ) out hi
 gpio-481 (                    |sdio_wifi           ) out hi
 gpio-482 (                    |sdio_wifi           ) in  hi
 gpio-492 (                    |bt_rfkill           ) out hi
 gpio-494 (                    |bt_rfkill           ) out hi

CE20 nightly





1 Like

Was that taken in Android? Because you need to take this info in Android, not from CoreELEC.

Was there no gpiochip1 output? There are two GPIO banks on Amlogic SoCs.
The output you posted doesn’t contain the information about which pins are used by the display.
And the vfd file you selected will not work with your box, as there are conflicting pins.

Sorry missed that part about Android I am using that VFD because that was what was asked. Report about Amlogic S905X4 HK1 RBOX X4 - #304 by Betatester

Running as normal and su there is no /sys/kernel/debug.

Android dmesg shows /sys/module/aml_fd655 for vfdsrv if that helps. Seems consistent with comments here GitHub - hkallweit/linux-amlogic-sc2 at sc2 Maybe the source there is needed?

Try this file.
hk1-rbox-vfd.conf (1.2 KB)
Reboot after replacing the other vfd file.

1 Like

Sorry no change, logs here if they help

Try this one.
hk1-rbox-x4-vfd.conf (1.3 KB)

If it doesn’t work, try to change
And reboot

Also, don’t post the whole kodi log, just use dmesg | paste from SSH.

Sorry, I just looked at the code, and it seems that the driver doesn’t support hardware I2C communication with these controllers.
You’ll have to disable the I2C interface in the DTB and then you should be able to use the conf file from my previous post here: How to configure VFD - #654 by TheCoolest

Thanks I will try a new dts later. Here are the full logs again, I thought you might what to see the python error in OpenVFD

That is expected behavior.

Here is the dtc output of the dtb I created that still doesn’t work. i2c disable dts - from what I can tell the only change from stock is i2c@6a000 is now also disabled.

You can use fdtput to set /soc/apb4@fe000000/i2c@6c000 status to disabled

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /soc/apb4@fe000000/i2c@6c000 status disabled

Just tried that, no change even in the dtc output.

Not dtc output. Use the normal dtb file, run the command and try the vfd from this post

I was only using dtc to see the changes. stock dtb.img with the ftput no changes here is dmesg

You didn’t use the correct vfd.conf file.

1 Like

CoreELEChk:~ # curl -o vfd.con
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1189    0  1189    0     0    796      0 --:--:--  0:00:01 --:--:--   796
CoreELEChk:~ # diff vfd.conf .config/vfd.conf
CoreELEChk:~ # sha256sum vfd.conf .config/vfd.conf
02f15edcd889504ff2c0363c7bf6b4706a78fcfcaa4405323cafee9f93932c1f  vfd.conf
02f15edcd889504ff2c0363c7bf6b4706a78fcfcaa4405323cafee9f93932c1f  .config/vfd.conf

Redownload it from the PC.

[   22.993247@1]- OpenVFD: vfd_gpio_clk:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 
[   22.993884@1]- OpenVFD: vfd_gpio_dat:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 
[   22.994675@1]- OpenVFD: vfd_gpio_stb:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 

means you’re running the vfd file with the hw i2c config.

1 Like

Ok cool that could be the problem all along now I get the clock, plus ethernet and play/pause images. Thanks for your patience. I will try with stock for fun.

Edit stock without a change didn’t work.

1 Like