How to get HDMI-CEC to work on AML-S905X-CC (Le Potato)

Hi, I’ve been using OSMC on a Raspberry Pi for a few years and now I wanted to be able to play H.265 and 4K video so I switched the Le Potato. I installed the latest CoreELEC and everything works perfectly but I can’t control KODI from my remote anymore. The remote is a Sony bluetooth touchpad (came with the TV) and it worked perfectly in OSMC. I know that there is a jumper on the board to enable/disable CEC and I’ve tried both settings but without any luck.

Also when I ask the TV to show my connected devices it does not list KODI only my PS4 and IPTV box. If I select HDMI port 2 (where KODI is connected) I get the picture but I must then use a keyboard to control it.

Is there anything else I should do to get it to work, (I’ve tried different HDMI 1.4 and 2.0 cables)? The Sony 4K TV is 3-4 years old.

Best regards
Nicke

CEC should be working already. At least it works on my Samsung and LG TV. Maybe you need to turn on the setting for the HDMI port.

Yes, it does. I feel really stupid because I tired the enable/disable the CEC jumper on every cable except the HDMI 2.0. When I now tried it again it works, I switched back to the old cable and it did not so it was a cable problem, sorry…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice