How to get shell screen when compiled without Kodi


I have compiled without Kodi by changing MEDIACENTER="no" in options.

I thought I will get into shell screen where it asks to login but I just see black screen with “Corelec (community)” text. I’ve tried hittting ctrl + c, ctrl + alt + f2.

How can I access shell?

From my notes:

Add “tty” or “debugging” to kernel boot params and a console will be available on CTRL+ALT+F3. The first just gives the console. The second also puts various subsystems into extra (and persistent) logging mode; as well as having the console.

Excuse my ignorance. How can I add “tty” to kernel boot params?

Edit file /flash/config.ini and add parameter under coreelec line (must be uncomment).

I set coreelec='debugging' and now I can see values like Unique identifier, framebuffer vertical res, etc…

But still no console in tty3(CTRL+ALT+F3).

Got it. coreelec='debugging textmode' did it. Maybe I don’t need debugging at all. I will check later. Thank you.

Update. Only textmode will do.

1 Like