How to install TVHeadend server?

Latest CE, Odroid N2+, Xbox One DVB-C tuner.

I tried installing and uninstalling in various combinations and rebooting after each change:

Tv Headend Server 4.2
Tv Headend Server 4.3
DVB Drivers for TBS
DVB Drivers from the latest kernel
TV Headend HTSP Client

Nothing works. According to the guides I found, I should be able to connect to the Odroid IP on port 9981. Just getting connection refused, so it’s not running I would say.
But how can I tell what’s going on?

Which add-ons are the ones that are correct to install?

I see a lot of AddOnLog: pvr.hts: unable to connect to 127.0.0.1:9982

http://ix.io/3XY0

Maybe the problem is similar with yours SSH issues. I would just do complete reinstall because something is wrong with your installation. It would be easier than figuring out what is the cause.

Setting up TV Headend
Troubleshooting network issues
Troubleshooting CoreELEC

My first thought when I read this is to wonder if you are using the Odroid’s Ip address. 127.0.0.1 is the Ip quoted in the instructions. In my case I use my N2’s IP which is 192.168.1.40.

Sorry if this is too simplistic, I don’t mean to offend.

No something is messed up in my N2+ since I can’t reach installed services and SSH doesn’t work either. I tried on my C2 and everything is fine there, so think I just have a crappy N2+. No matter how many times I try to reinstall. something new always doesn’t work.

On my devices, after a first clean install, I always check firstly that CoreELEC has taken a correct local IP address, and secondly, that SSH is working. There have been times when this has not happened and the possible causes are:

  • Errors in the storage medium (for example, I remember once years ago that I installed LibreELEC x86_64 on a USB disk with NTFS format).

  • Errors in assigning the local IP address (for example, the device cannot connect via WiFi due to interference or other causes and it may be necessary to restart the router, or it may also happen that there is an address conflict - two devices with the same IP address or static address assignment on the device that the router refuses to set, in this case use dynamic DHCP assignment on the device and set the static address on the router-).

Check all this and don’t install anything until SSH works!

I use the eMMC I got from hardkernel. IP is fine as I can control Kodi via HTTP and access it via SMB from Windows.

I don’t understand why it is possible to be so prone to different errors just copying some files to an eMMC card

I have 3 devices with detachable emmc, 2 from Odroid. Never had a single problem with them. We can’t generalize the same way we can’t say you’re doing something wrong. If I would have to make an estimate I would put my money on 5% is an equipment problem, 95% user problem. Which means that some devices can be faulty.