How to make AAC sound play? (with bitstream)

I got Coreelec 19.4 on Mecool KI PRO and Coreelec 19.5 rc2 on Tanix TX3. Both work great with movie files with DTS, DTS-MA, DTS-X,DD, DDPlus (Atmos), Dolby-TrueHD, Atmos). I 'm bitstreamin all sound to my Anthem receiver, all types of streams are enabled in hardware> sound section.
I have some small size movie files with AAC sound, no matter 2.0, 5.1 or 7.1, but when playing the there is no sound, its not recognized by amplfier.
I know we can’t bitstream AAC to amp but how to make it work? Can be even 2.0 stereo…
For example Oppo player convert AAC to PCM ant then stream it to receiver.
How to watch movies with AAC on coreelec?

I’m stupid, must select hdmi Multichannel PCM as audio output and the pcm is send to receiver. No affect to bitstream.

Hi all,
just did a clean install of Nexus 20 final on my Mecool K1 Pro. System works as expected. All audio encodings work fine (ie DTS, DTS-MA, DTS-X,DD, DDPlus (Atmos), Dolby-TrueHD, Atmos) except for some AAC 5.1 encoded files which play (stutter rather) without sound. K1 Pro is connected to one HDMI input on the amp (Onkyo TX-NR575E) and the amp is connected to the video projector via the output HDMI. Couple of questions:

  • Is it a know fact that the K1 pro cannot output AAC 5.1? I have not come across such encodings before. Or is it a Nexus thing…
  • Can I do anything to enable the proper audio sink? I don’t have the “hdmi Multichannel PCM” option in the list under System => Audio as @headmax mentions in his OP.

I am at a loss and need some help.

P.S. Will re-install with 19.5 final to compare when I have time and will let you know.

== Update==
Did not take me long to just do a vanilla install of CE 19.5. Same problem. Same audio sink choices listed. But noticed that sound will play in a 2.0 speaker configuration (with the same audio sink as in CE 20.0). If I switch to a 7.1 config, sound disappears and video stutters. The files have AAC 5.1 audio as confirmed with the video overlay. Pity. Anyone solved this?

OK. Will oblige when possible.

After clean install
Or New install
System is set to default settings

Change settings to expert
Then in Audio will have advanced functions

And will see Audio output device list is multiple configs

Then move to Allow pass-through
Allow pass-through to receiver…

Maybe will help

Happy Testing

Thanks for chiming in but I’m afraid I already did all that. To no avail.

@Portisch OK, installed CE 20.0 final on Mecool K1 pro. Set keyboard to French. Set level to expert. Added one source (NFS). Set audio to passthrough (7.1 channels). Set logging options to audio and video. Played an MP4 file with AAC 5.1 audio. No sound and no image.
Here’s the log :
Hope that is helpful. By the way, I could not upload just the logs and configs, had to choose the second option in Settings => Coreelec => System.

I’m upping this in the hope someone can help me troubleshoot my problem. Pretty please. :pray: