How to make AAC sound play? (with bitstream)

I got Coreelec 19.4 on Mecool KI PRO and Coreelec 19.5 rc2 on Tanix TX3. Both work great with movie files with DTS, DTS-MA, DTS-X,DD, DDPlus (Atmos), Dolby-TrueHD, Atmos). I 'm bitstreamin all sound to my Anthem receiver, all types of streams are enabled in hardware> sound section.
I have some small size movie files with AAC sound, no matter 2.0, 5.1 or 7.1, but when playing the there is no sound, its not recognized by amplfier.
I know we can’t bitstream AAC to amp but how to make it work? Can be even 2.0 stereo…
For example Oppo player convert AAC to PCM ant then stream it to receiver.
How to watch movies with AAC on coreelec?

I’m stupid, must select hdmi Multichannel PCM as audio output and the pcm is send to receiver. No affect to bitstream.

Hi all,
just did a clean install of Nexus 20 final on my Mecool K1 Pro. System works as expected. All audio encodings work fine (ie DTS, DTS-MA, DTS-X,DD, DDPlus (Atmos), Dolby-TrueHD, Atmos) except for some AAC 5.1 encoded files which play (stutter rather) without sound. K1 Pro is connected to one HDMI input on the amp (Onkyo TX-NR575E) and the amp is connected to the video projector via the output HDMI. Couple of questions:

  • Is it a know fact that the K1 pro cannot output AAC 5.1? I have not come across such encodings before. Or is it a Nexus thing…
  • Can I do anything to enable the proper audio sink? I don’t have the “hdmi Multichannel PCM” option in the list under System => Audio as @headmax mentions in his OP.

I am at a loss and need some help.

P.S. Will re-install with 19.5 final to compare when I have time and will let you know.

== Update==
Did not take me long to just do a vanilla install of CE 19.5. Same problem. Same audio sink choices listed. But noticed that sound will play in a 2.0 speaker configuration (with the same audio sink as in CE 20.0). If I switch to a 7.1 config, sound disappears and video stutters. The files have AAC 5.1 audio as confirmed with the video overlay. Pity. Anyone solved this?

OK. Will oblige when possible.

After clean install
Or New install
System is set to default settings

Change settings to expert
Then in Audio will have advanced functions

And will see Audio output device list is multiple configs

Then move to Allow pass-through
Allow pass-through to receiver…

Maybe will help

Happy Testing

Thanks for chiming in but I’m afraid I already did all that. To no avail.

@Portisch OK, installed CE 20.0 final on Mecool K1 pro. Set keyboard to French. Set level to expert. Added one source (NFS). Set audio to passthrough (7.1 channels). Set logging options to audio and video components. Played an MP4 file with AAC 5.1 audio. No sound and no image.
Here’s the log :
Hope that is helpful. By the way, I could not upload just the logs and configs, had to choose the second option in Settings => Coreelec => System.

I’m upping this in the hope someone can help me troubleshoot my problem. Pretty please. :pray:

Feeling a bit lonely here … I know the devs are pretty busy but I would love for some knowledgeable people to see if they can tell me what is wrong with the playing of media files with AAC 5.1 audio on my Mecool K1 pro. See above post, the one with the log file. TIA

Do your media files have to play with AAC5.1 audio output format? I ask this because such media files with AAC5.1 audio play OK with audio transcoded to DD5.1 on all my CE/Kodi devices…

No, all I want is for them files to play with sound. For now no matter what audio sink I choose, there is no sound. I have turned audio passthrough on and all my amp’s capabilities are turned on as well (Dolby Digital capable, E-AC3 cablable, DTS capable, TrueHD capable, DTS-HD capable). I don’t see any option to transcode to DD5.1 on my setup.

according coreelec:audio [CoreELEC Wiki]
" For AAC 5.1 and 7.1 audio on 5.1 and 7.1 systems connected via HDMI, select HDMI Multi Channel PCM output, and set the corresponding Number of Channels"

Thanks for taking an interest. I am aware of the multi-channel requirement. Trouble is I have no such option in the audio settings of the system page. See picture. I am asking for help because I cannot make much sense of the logfile I provided.

First, use default Estuary skin.
Second, in Player Settings do not use Sync Playback to Display

In System Settings - Audio:
First, choose HDMI Audio output device, one that is not PCM
Second, choose Number of channels 2 (two)
Third, set Output configuration to Best Match
Fourth, enable Allow Passthrough
Fifth, choose HDMI Passthrough output device that enables additional setting for:
Sixth, enable Enable Dolby Digital (AC3) transcoding.

This is how raw AAC5.1 audio is output to DD5.1; works on all my Kodi devices.


Thanks to your short guide, works now. Much appreciated :+1:. I would never have thought of setting the number of channels to 2 as I was under the (wrong, I realise) impression that that was only for systems using SPDIF out and I am using HDMI out. Anyways, I am a happy camper now. Again, thank you.

:grin: you are not the first nor last that has headaches with this “controversial” 2 channel setting since Kodi Wiki only states:
Note: S/PDIF supports 2.0 channels only but can still output multichannel audio using a format supported by passthrough.
The part after but is often overlooked and does not include HDMI output support…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.