How to manipulate remote files?

Hello friends.
I am a complete newbie with CoreELEC so hope you will pardon my silly question.
Following the tutorial I have sucessfully installed CoreELEC-Amlogic-ng.arm-9.2-nightly_20190914-Generic.img.gz on S905X2 Vontar X96MAX box with 4GB RAM and 1Gbit LAN.

And while the picture is little croped (90%) my bigest issue is that no one of the three remotes that I have (box original, Sony TV, Sony Blue-Ray) works.

I know that there is option to configure remote, but my issue is not knowing where can I find this file and how should I access them?

While CoreELEC is running, I cant do anything from the box, as no remote is working. I have tried to find device in my network but could not find anything. I have tried to access with ssh, like ssh root@device ip adress and get responce like ssh: connect to host device ip port 22: Connection refused.

So how can I access place where remote files are located and how can I edit or manipulate them so I can make at least one remote to work. Any guidence or how-to with photos or videos will be highly apreciated.

Thank you.

You should not have problems with SSH access. Check that (1) the CoreELEC SSH server has been enabled in the initial installation process, that (2) you know the IP address of your TV Box within your home network, and that (3) you know the username (root ) and initial SSH access password (coreelec).

If you have not been able to do this because no IR remote control works, not even the IR remote control of your TV, then you will need a generic USB remote control or keyboard. Later, when you have SSH access then you can configure any IR remote control.

1 Like

Check your tv’s settings.

Thank you for the fast reply.
Would you be kind enough to teach me / explain how to check all this things, preferably with photos, or point me to some turorial. I have searched anythiing but didnt find any straightforward tutorial.
Thank you.

A search of this forum might be a start

Hello to everybody.
I postprone my CoreELEC project untill I purchase new TV. Now equiped with new TV and remote, I tried to reprogram TV remote keys to work with CoreELEC. I think I have done everything right yet the remote do not work. Can you please look at my files and tell what is wrong?
RMT_TX300E (850 Bytes) rc_maps.cfg (21 Bytes)
After running
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
I got
Old keytable cleared
Wrote 39 keycode(s) to driver
Yet remote does not work

I see 2 mistakes, read an instruction(red part):

  1. You have # deleted in the beginning
  2. Your files are in windows format, you need convert them in Unix format.
    Use Notepad++, Edit->EOL conversion->Unix

Yes, you are right. I looked into it, set as you recommend and it works.
Now have most stupid problems that didnt anticipated. The ENTER key, on the remote, works with CoreELEC but unfortunatly it calls input selection on the TV as well despite having another button for this.

Does anyone knows how to turn off this action on the TV (Sony XG7096)?

Hi, I’m new to the forum, the question may be too new. I currently have an EMINENT EM760 player running CE 9.0.1. The remote control works perfectly (factory remote control, installed from the link provided on eminent page). I wanted to switch to CE 9.2.1, installation successful but remote control not working. I’ve just returned to 9.0.1. The question would be how to copy the remote conf file to CE9.2.1? Or is it possible? Thanks for the help!

It apears that there is no option to change the behaviour of the TV, now my only option is to enable HDMI-CEC which didnt worked from start. TV just does not want to see my box.
Is there any known problems with Coreelec and HDMI-CEC?
Does it require some special cables?
Is there some option that can be modified in the way the remote file can be modified to try to make HDMI-CEC to work?

CEC does not need any “special” HDMI cable, but it needs one that contains CEC wire. There are HDMI cables that don’t have wire needed for CEC, so trying with another HDMI cable is good idea.
CEC pin 13 is used for CEC, see here.

Solved the problem. HDMI cable was root cause.
HDMI-CEC now works as a charm. So no need for remote reconfiguration.

Glad you sorted the problem with a simple solution :slight_smile:

Btw, inappropriate HDMI cables seem to cause most problems probably due to the cheap (crap) cables sold along most of Chinese boxes…