Hyperion.NG, Amlogic improvements

Please describe in detail what client and source is used. I use Hyperion.NG now for years on daily basis without one crash.

Hyperion Server:
- Build:             coreelec-20 (Peter-d2aa3bbc11/c38593970c-1668768867)
- Build time:        Nov 19 2022 04:04:39
- Git Remote:        https://github.com/CoreELEC/CoreELEC.git
- Version:           2.0.13
- UI Lang:           pl (BrowserLang: pl-PL)
- UI Access:         default
- Avail Screen Cap.: framebuffer,amlogic,qt
- Avail Video  Cap.: v4l2
- Avail Services:    boblight,cec,effectengine,forwarder,flatbuffer,protobuffer,mDNS,SSDP,borderdetection
- Config path:       /storage/.kodi/userdata/addon_data/service.hyperion.ng
- Database:          read/write

Hyperion Server OS:
- Distribution:      CoreELEC (official): 20.0-Nexus_nightly_20221119
- Architecture:      arm64
- CPU Model:         Amlogic S922X rev a
- CPU Hardware:      Beelink
- Kernel:            linux (4.9.269 (WS: 32))
- Root/Admin:        true
- Qt Version:        5.13.0
- Python Version:    3.11.0
- Browser:           Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Sources - no relation - happens on movies/series from Netflix, from Disney, HBO Max. It happens on avi files from NFS, it happens on files from other sources (from external services).
Sometimes the whole day of playback nothing happens - sometimes 3-4 times a day on different sources, and in a moment on the same sources it’s OK.
That’s why checking with me takes a bit longer - now I’m checking on the versions above - so far 2 movies OK.
You have earlier errors in previous posts - now I’m testing and waiting for a “surprise”

So all use Widevine? I don’t use it much, just yesterday one movie on Amazon. No issues.
I will need to make another debug build only for this as the dmesg will be flooded.

I did not install widevine and I’m not playing any DRM content. My sources are either videos on a NFS share or YouTube videos using the YouTube plugin.

No, not only on DRM - on any sources… DRM, IPTV, localfiles, from plugins (avi/mkv/mp4 - differents codecs,resolution,sound)

New crash (after 3-4 movies - the last one was from Disney+, another was from plex - with Composite addon - for example:

Duration 1:07:52
Bitrate 8726 kbps
Width 1920
Height 1080
Aspect Ratio 1.78
Video Resolution 1080p
Container MKV
Video Frame Rate 24p
Audio Profile lc
Video Profile high
Codec H264
Bitrate 11998 kbps
Język angielski
Language Tag en
Bit Depth 8
Chroma Location left
Chroma Subsampling 4:2:0
Coded Height 816
Coded Width 1920
Frame Rate 23.976 fps
Height 804
Poziom 4.1
Profil high
Ref Frames 5
Scan Type progressive
Width 1920
Display Title 1080p (H.264)
Extended Display Title 1080p (H.264)

Crash was on Disney+ and last ANDOR.
CoreELEC (official): 20.0-Nexus_nightly_20221119 (Amlogic-ng.arm)
The same error as rwlove:

<1>[24252.598818@0]h pgd = 0000000065d40b93
<1>[24252.598821@0]h [0000000000020000] *pgd=00000000bddf6003, *pud=00000000bddf6003, *pmd=00000000ad242003, *pte=00200000b0ce3fd3
<0>[24252.598835@0]h Internal error: Oops: 8600000f [#1] PREEMPT SMP```

I’ve been using hyperion for probably k17 - and only this year these problems appeared - but first I blamed them on the cables, power supply, etc
II checked when I first talked about this weird crash on the polish kodi group - December 27, 2021 - but first the box and cpu overheating were blamed, then the power supply, then the cables, then the box itself, then cables/power supply/leds/arduino again - and each test took a long time. All these elements have been excluded several times by replacing them

Last crash:
2d without hyperion (disabled addon - but still connected to usb) - works. 1-2h after turning on hyperion - crash
Coreelec 20 - last nightly - 20221119

Ok, maybe it’s a longshot but I had Hyperion.ng weirdness once in the past and it was a faulty usb type B cable. I had one of those pre-made chinese kits powered by arduino and the cable that was in the set caused some kind of electric impulse/interference which my device was detecting and disabling that particular USB port until next reboot to prevent hardware damage. Replacing that USB cable that goes from your device to the Hyperion control box (like Arduino) is worth a shot IMHO.

As for the cables. I replaced the Chinese power supply with a solid one (made in EU), I replaced the USB cable - but I can’t tell if it wasn’t some chinese - I just took another one that I had at home. I will buy a new cable today and check.
All in all, it could make sense - this randomness that once after a few hours, once after a few days / weeks. That’s why I started with replacing the cables and the power supply/leds/arduino/box before I reported the problem - but maybe the USB cable was also chinese (the new one also will be from china…

It’s worth a try :wink: btw. here’s a link to the topic where I was fighting with my issue: CoreElec disables internal USB HUB - "port 1 disabled by hub (EMI?)"

Thx (Dzięki bo my chyba w tym samym języku mówimy z tego co pamiętam)

No worries :wink: (tak jest, nie ma problemu)

I connected another cable, no change. I changed the connection from usb2 to usb3 - so far it works …

Unfortunately, changing the cable didn’t help.
I had to change k20 to k19 due to the incompatibility of one of the plugins I use. I checked on the last nightly k19: CoreELEC (official): 19.5-Matrix_nightly_20221118 (Amlogic-ng.arm), on 2 different USB ports.
I can’t replace/check more things - and without lights it’s not the same…
Any chance of a solution?
I’ll check on the second arduino board.

@ tomasiek You are using the screecapture (amilogic) feature of Hyperion, correct?
Please confirm.

The dumps point into that direction that the capturing a screen frame does not work.
It is not a Hyperion problem, but it uncovers the problem area, as Hyperion asks for a frame.
Similarly, it has nothing to do with USB…

BTW - I also ruled out a problem with the box - it happens on two different devices

I had no time to check this issue. I tried to make it more save but it still had a oops. To be honest I wasn’t working for the last 6 months anymore on 4.9 kernel and it’s not so comfortable working on it like on 5.4. I will require more time

Of course. Each of us has his own life. So I’m waiting, but I hope that the problem has finally been identified.