Hyperion.NG, Amlogic improvements

Under test now. I’m going to try to keep it running most of the day.

ok, but i won’t be able to check until after the weekend

Below are ramoops from crashes using your image. I’m not sure I categorized them perfectly, but I noticed that there seem to be different log messages for different crashes.

Null pointer:

[10734.613175@0]h Internal error: Oops: 96000007 [#1] PREEMPT SMP

<1>[ 5104.200580@0]h Unable to handle kernel paging request at virtual address 00020000 <1>[ 5104.200587@0]h pgd = 00000000d92167b3 <1>[ 5104.200589@0]h [0000000000020000] *pgd=00000000b456d003, *pud=00000000b456d003, *pmd=00000000b79f4003, *pte=00200000b3064fd3 <0>[ 5104.200598@0]h Internal error: Oops: 8600000f [#1] PREEMPT SMP

Still no go here. uninstalled reinstalled. CE says the addon is running but cannot access the web interface. reverted to 11/12 and running again

“The file you are trying to download is no longer available” :frowning: So I can’t test
Unfortunately - on the latest nighthly coreelec 20 from 11.19 - Hyperion does not start at all (even with fresh start)
OK - after few restarts and reinstalls it works on 20221119
Testing :slight_smile:

Please describe in detail what client and source is used. I use Hyperion.NG now for years on daily basis without one crash.

Hyperion Server:
- Build:             coreelec-20 (Peter-d2aa3bbc11/c38593970c-1668768867)
- Build time:        Nov 19 2022 04:04:39
- Git Remote:        https://github.com/CoreELEC/CoreELEC.git
- Version:           2.0.13
- UI Lang:           pl (BrowserLang: pl-PL)
- UI Access:         default
- Avail Screen Cap.: framebuffer,amlogic,qt
- Avail Video  Cap.: v4l2
- Avail Services:    boblight,cec,effectengine,forwarder,flatbuffer,protobuffer,mDNS,SSDP,borderdetection
- Config path:       /storage/.kodi/userdata/addon_data/service.hyperion.ng
- Database:          read/write

Hyperion Server OS:
- Distribution:      CoreELEC (official): 20.0-Nexus_nightly_20221119
- Architecture:      arm64
- CPU Model:         Amlogic S922X rev a
- CPU Hardware:      Beelink
- Kernel:            linux (4.9.269 (WS: 32))
- Root/Admin:        true
- Qt Version:        5.13.0
- Python Version:    3.11.0
- Browser:           Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Sources - no relation - happens on movies/series from Netflix, from Disney, HBO Max. It happens on avi files from NFS, it happens on files from other sources (from external services).
Sometimes the whole day of playback nothing happens - sometimes 3-4 times a day on different sources, and in a moment on the same sources it’s OK.
That’s why checking with me takes a bit longer - now I’m checking on the versions above - so far 2 movies OK.
You have earlier errors in previous posts - now I’m testing and waiting for a “surprise”

So all use Widevine? I don’t use it much, just yesterday one movie on Amazon. No issues.
I will need to make another debug build only for this as the dmesg will be flooded.

I did not install widevine and I’m not playing any DRM content. My sources are either videos on a NFS share or YouTube videos using the YouTube plugin.

No, not only on DRM - on any sources… DRM, IPTV, localfiles, from plugins (avi/mkv/mp4 - differents codecs,resolution,sound)

New crash (after 3-4 movies - the last one was from Disney+, another was from plex - with Composite addon - for example:

Duration 1:07:52
Bitrate 8726 kbps
Width 1920
Height 1080
Aspect Ratio 1.78
Video Resolution 1080p
Container MKV
Video Frame Rate 24p
Audio Profile lc
Video Profile high
Codec H264
Bitrate 11998 kbps
Język angielski
Language Tag en
Bit Depth 8
Chroma Location left
Chroma Subsampling 4:2:0
Coded Height 816
Coded Width 1920
Frame Rate 23.976 fps
Height 804
Poziom 4.1
Profil high
Ref Frames 5
Scan Type progressive
Width 1920
Display Title 1080p (H.264)
Extended Display Title 1080p (H.264)

Crash was on Disney+ and last ANDOR.
CoreELEC (official): 20.0-Nexus_nightly_20221119 (Amlogic-ng.arm)
The same error as rwlove:

<1>[24252.598818@0]h pgd = 0000000065d40b93
<1>[24252.598821@0]h [0000000000020000] *pgd=00000000bddf6003, *pud=00000000bddf6003, *pmd=00000000ad242003, *pte=00200000b0ce3fd3
<0>[24252.598835@0]h Internal error: Oops: 8600000f [#1] PREEMPT SMP```

I’ve been using hyperion for probably k17 - and only this year these problems appeared - but first I blamed them on the cables, power supply, etc
II checked when I first talked about this weird crash on the polish kodi group - December 27, 2021 - but first the box and cpu overheating were blamed, then the power supply, then the cables, then the box itself, then cables/power supply/leds/arduino again - and each test took a long time. All these elements have been excluded several times by replacing them

Last crash:
2d without hyperion (disabled addon - but still connected to usb) - works. 1-2h after turning on hyperion - crash
Coreelec 20 - last nightly - 20221119

Ok, maybe it’s a longshot but I had Hyperion.ng weirdness once in the past and it was a faulty usb type B cable. I had one of those pre-made chinese kits powered by arduino and the cable that was in the set caused some kind of electric impulse/interference which my device was detecting and disabling that particular USB port until next reboot to prevent hardware damage. Replacing that USB cable that goes from your device to the Hyperion control box (like Arduino) is worth a shot IMHO.

As for the cables. I replaced the Chinese power supply with a solid one (made in EU), I replaced the USB cable - but I can’t tell if it wasn’t some chinese - I just took another one that I had at home. I will buy a new cable today and check.
All in all, it could make sense - this randomness that once after a few hours, once after a few days / weeks. That’s why I started with replacing the cables and the power supply/leds/arduino/box before I reported the problem - but maybe the USB cable was also chinese (the new one also will be from china…

It’s worth a try :wink: btw. here’s a link to the topic where I was fighting with my issue: CoreElec disables internal USB HUB - "port 1 disabled by hub (EMI?)"

Thx (Dzięki bo my chyba w tym samym języku mówimy z tego co pamiętam)

No worries :wink: (tak jest, nie ma problemu)

I connected another cable, no change. I changed the connection from usb2 to usb3 - so far it works …