Hyperion.NG, Amlogic improvements

Unfortunately, changing the cable didn’t help.
I had to change k20 to k19 due to the incompatibility of one of the plugins I use. I checked on the last nightly k19: CoreELEC (official): 19.5-Matrix_nightly_20221118 (Amlogic-ng.arm), on 2 different USB ports.
I can’t replace/check more things - and without lights it’s not the same…
Any chance of a solution?
I’ll check on the second arduino board.

@ tomasiek You are using the screecapture (amilogic) feature of Hyperion, correct?
Please confirm.

The dumps point into that direction that the capturing a screen frame does not work.
It is not a Hyperion problem, but it uncovers the problem area, as Hyperion asks for a frame.
Similarly, it has nothing to do with USB…

BTW - I also ruled out a problem with the box - it happens on two different devices

I had no time to check this issue. I tried to make it more save but it still had a oops. To be honest I wasn’t working for the last 6 months anymore on 4.9 kernel and it’s not so comfortable working on it like on 5.4. I will require more time

Of course. Each of us has his own life. So I’m waiting, but I hope that the problem has finally been identified.

bTW what if I manually uploaded only the kernel.img from the time when there was no error? i.e. before December 2021? Leaving the rest of the files as they are.
I went back to 19.3Matrix on Oct 25, 2021 - that was probably the last time it was ok… testing.
Nevermind - the same crash - i’ll try to use usb graber instead of amlogic

Please use this image:

Maybe use another boot media as it’s a debug build. When the kenel oops happen again please post the log, thx.

Crash with this image

And another (after ~1,5h)

(USB graber - it does not support HDMI-CEC, which excludes it from use)

I was now able to create a debug image of the kernel and it point me to this line:

Will need to take a look what happen here. Maybe the callback get invalid while enter here, not sure.

Please make a log of the kernel oops again with this image, just to be sure I am looking on the correct line:

Ok - I’ll check it right now - we’re just starting to watch


Please test with this image again and post a new log on crash:

Ok - last test take about 3h…


Ok, next test image:

Approx. I think this will be my last test today - matches finished :slight_smile:

The lights have been working for a few hours - so far without a problem, but it doesn’t mean anything yet because it happened that it worked for a few days and it was ok.

I think I covered the issue, but it should happen. I will make another debug image to find the reason.
But I will need more time to look what be the best solution for it. So continue testing with last image please.

After a few hours you can run on SHH:
dmesg | grep ++++ and see if you get some output. If yes the error happen but the system did not crash.

I’ve been watching something since 8:00 in the morning. It didn’t hang up. Yes, while watching one game he hung up (but it happens on this site). Hyperion is still running.

[36487.840449@0]h ++++ ext_frame_capture_poll(1496) 
[36487.840456@0]h ++++ ext_frame_capture_poll(1499) 
[49258.884088@0]h ++++ ext_frame_capture_poll(1496) 
[49258.884095@0]h ++++ ext_frame_capture_poll(1499)

I’ll keep testing and will post another log tonight. Well done - I had no more ideas what could be the cause.

Thank you for everything - you put a lot of work into this. But as you can see with the effect.

Still works… You are great.