Hyperion.NG, Amlogic improvements

Thanks so much!

I couldn’t find your pull request on the CoreElec repo, so I cloned your fork and it’s currently compiling.
As soon as I get around to testing I will let you know. If everything goes well, mind if I post a compiled version on the topic I linked to help out the people struggling with the same issues?

Running into an issue on the compile, seems like it can’t fetch the amlogic source

Cannot get linux sources : https://github.com/CoreELEC/linux-amlogic/archive/cf89c0adf65988364a85831394ba88f372b79578.tar.gz
Try later!
FAILURE: scripts/build linux:host has failed!
[19/87] [FAIL] build   linux:host

I think you have to pull on your local CoreELEC clone. I can’t find any cf89c0adf65988364a85831394ba88f372b79578 in linux history.

Also maybe it’s needed to compile other depencies by:
PROJECT=Amlogic-ng ARCH=arm make
This build CE image, then try again building the addon.

Think I found my mistake… (After fetching the right branch from your repo :smiley:)

Initially tried to compile on a rock64, when that failed I tried the RPI3 (which gave me a nice msg about not being able to build on raspbian). Currently it’s compiling on a x64 chip, now on linux:host step, since it’s not crashing instantly I think it’s working.

Managed to compile your repository and test it on my box but the problems I needed to fix remained

  • Live video feed doesn’t work (not a problem as long as the LED view works)
  • Reds and blues were still swapped on the grabber

But with your help I forked your repository and made the change as mentioned in topic I linked, changed the code and pointed the coreelec package.mk for the addon to my new repository, compiled it and now it the grabber has the correct colors :smiley:

I noticed that they changed the code a bit since last time someone looked at it and it might be that something isn’t enabled on my system.

This is the line of code I had to change from BGR32…

But if ENABLE_AMLOGIC would’ve been true it would’ve done that automagically, so seems like a bug or something in my config?

Anyway, here’s a link to the compiled addon in case anyone needs it: https://github.com/MunkeyBalls/hyperion.ng/releases/download/0.1/service.hyperion.ng-9.2.102_RGBfix.zip

I updated the Hyperion.NG Addon at CoreELEC. I am not sure if it get updated in the Repo as Nightlies are switched off right now. So here the link to the new version if someone want to load it:
https://test.coreelec.org/Portisch/service.hyperion.ng-9.2.102.zip

Be aware that the Hyperion.NG configuration file changed from hyperion.config.json to hyperion.db. I found no way to convert the json config into the database config, so you have to setup a new config by the Hyperion.NG web interface.

@MunkeyBalls I am not sure about the change. It looks like a “old” bug from hyperion (before hyperion.ng). But I guess a lot of users are switching the colors on the LED hardware like me. So I am afraid breaking a running system.

2 Likes

What did you change?
Im asking because I do not have any problems and I ask myself if i want to “change the running system” :wink:

I changed nothing, I just updated to the current status of the master branch of Hyperion.NG

Updated and reconfigured and working fine, thanks!!

same here.
Import of old config did not work. I had to redo the settings.
Now everything is working again. Thank you!

Tomorrow should version .103 available in CoreELEC repo with some big improvements: https://github.com/CoreELEC/CoreELEC/pull/226

External grabber should work now and WebUI preview is fixed.

Many thanks to @Paulchen-Panther!

3 Likes

Will hyperion.control work with this version?
(https://github.com/hyperion-project/hyperion.control)

Yes I think so.

This is great to see.

I’m new to plugins in coreelec.
I have coreelec 9.2.1, under plugins I’m seeing version, 101,
It looks to be the version from July

What should I be doing to see newer versions?

I think you need to use the nightly image of CoreELEC.
But you also can download it here: https://relkai.coreelec.org/?dir=addons/9.2/Amlogic/arm/service.hyperion.ng

Then just install it with the ZIP file mode in Kodi User Addons.

REMEMBER: since .102 the user config structure changed and you have to setup a new config by the WebUI of Hyperion.NG by access the WebUI: http://<your-box-ip>:8090

2 Likes

I am experiencing that when I reboot, hyperion starts but didn’t show the rainbow.

Hyperion it’s started but the leds doesn’t turn on, if I go to the webUI I see in remote controls that the amlogic grabber is not selected due to the priority, effects appears with priority 0!

Can I modify the priority values?

In standard hyperion I remember that I can define the priorities in the json, but now?

This is what happens after a reboot, didn’t show the rainbow and it keeps “freezed” in hyperion, and because that, the amlogic grabber don’t work.

Whe I press the clear all effects/colours button, then amlogic grabber starts to work. But I have to do this manually everytime.

I jsut have done a clean install of .103 here and it shows me:
System Effect: Warm mood blobs Priority: 254

But I do not know where and if it is possible the change the priority.
I am sure @Paulchen-Panther knows more about it.

is there a way to disable Hyperion while in Kodi menu? I do not switch off Corelec box and end up with backlight, so everytime I have to physically unplug hyperion hardware. It’s very annoying

Try https://github.com/hyperion-project/hyperion.control

2 Likes

About | FAQ | Terms of Service | Privacy Policy | Legal Notice