Hyperion.NG, Amlogic improvements

I keep mine 24/7, on standard hyperion I can disable UI grabbing, but in ng doesn’t.

I use the black screensaver, when i don’t use it, the screensaver turn the leds off.

I’ll try to uninstall, reinstall and configure it again

Tried to reinstall v.103 and the same behaviour. If I reboot, the rainbow doesn’t appear when booting coreelec, and keeps freezed, and amlogic grabber doesn’t start to work till I kill the Rainbow effect under remote controls.

Tried with v.102, and the same.

And v.101 works perfect. Rainbow starts when bootin coreelec, and amlogic grabber starts to work after the Rainbow.

On all versions I configured all from 0, with same parameters in the webUI


This is how it looks like on my device. You have priority 0 and a red “X” next to the select source button.
Maybe you remove the addon again and manually check if all about Hyperion is deleted in folder Addons and Userdata/addon_data.
Also be sure the old Hyperion is removed!

Will check again, and manually delete files/folders if necessary

To turn off hyperion in GUI - use hyperion.control - works great with version 103, you just need to disable API login at :8090.

Uninstalled, and checked manually if all related to hyperion is deleted.

Installed and configured 103 again, reboot and again rainbow doesn’t work when booting and I have to stop it manually from remote control.

It happens in some users on a telegram group, not only me.

The only way to start the leds after a reboot or power on, is to stop hyperion addon and run it again, or “killing” the boot effect from remote control.

With 101 works just fine

Then deactivate the addon in Kodi Addons menu.
Restart your box and open a SSH connection.

Start hyperion.ng by this command:
hyperiond --userdata /storage/.kodi/userdata/addon_data/service.hyperion.ng -d

You will receive then debug output from the start of the addon in the SSH console.

I will try, but I think that we don’t see anyrhing doing this, because if I start manually the addon all works perfect.

The problem is whith the addon activated, something goes wrong when booting and auto starts the service during it.

@Alestilohomer
Which hardware do you actually use to control your LEDs?

I have a X96 Max s905x2 4/64, and the leds are controlled with an arduino nano

Could you please try this version?

As a test, I have reversed this code.


This was introduced in order to prevent forwarder clients from constantly switching between the priority of the grabber (254) and the boot effect (0) if the Client was started before the host starts.

Tested, it works!

Doesn’t show the Rainbow effect during CE boot, but it doesn’t “freeze” the effect and amlogic grabber works without killing effects or turning off/on the service.

Could you please set Hyperion.NG logging to debug in the WebUI, restart CE and post the logging output to me? Thank you.

Sure! Thanks to you!

This is with v103 provided by you.debug.txt (4.7 KB)

For the sake of pure interest. Have you ever tried to extend the duration of the boot effect?

edit1: Or maybe shorten the time the device is delayed:

edit2: One could assume that the two default delays in the source code result in exactly 3000ms of the boot effect:

1 Like

Correct, with 7000ms duration I can see the rainbow. So seems that all is ok now.

Thank you!

1 Like

Hello to each other, when is the hyperion.ng 2.00 in the repo?
Or can someone compile the 2.00 for Arch64?

why? what do you miss?

I mean the new version 2.0.0.
Maybe you can already install them in CE.
https://github.com/Paulchen-Panther/hyperion.ng/releases/tag/2.0.0

About | FAQ | Terms of Service | Privacy Policy | Legal Notice