Hyperion.ng external grabber no /dev/video0


#1

I moved from krypton libreelec to coreelec, as i use on krypton hyperion with external grabber UTV007 i install hyperion.ng addon, set it from webpage but i cant use my external grabber?

My lsusb show Bus 001 Device 002: ID 1b71:3002 Fushicai USBTV007 Video Grabber [EasyCAP]
but i cant find /dev/video0 directory so leds dont work, the same box on krypron from kszaq, all work fine.

Is coreelec misses some driver or did something wrong?

Hyperion is set correctly, cause on internal grabber all works fine, but as all know internal grabber on amlogic box have bug.


#2

Really noone :slight_smile: adamg i think its hardware problem, hyperion.ng works fine, but my grabber utv007 after connect to box not create /dev/video0 that way i put my question in hardware group :slight_smile:


#3

I don’t have my TV modified with LED’s for Hyperion so I can’t help much but @danielfmo is our resident Hyperion expert.

The Krypton builds by kszaq use a different version of Hyperion as well.


#4

Actually @adamg they are right, nothing to do with Hyperion but rather by the drivers that are not loaded.

Believe that a modprobe command may fix the issue but I don’t know which one, can you help?


#5

I read somewhere its usbtv, but when i modprobe it i got not found :frowning: cause bug in amlogic grabber i bought external grabber, so it will be nice to add support, drivers to the build of coreelec.


#6

Have you tried to install and enable crazycat drivers as this is where all drivers for external media devices was moved to?


#7

Yes, i tried crazycat drivers, but still nothing. It contains only dvb drivers.

I check old sdcard with kszaq build, and modules name are usbtv some modules with videobuf2, iam not sure what modules are used.

In kszaq build inside lib/modules folder you can find “update” directory, it contains most modules which in coreelec you cant find.

I try insmod usbttv module but i got Unknown symbol in module.


#8

try to enable hauppauge then ssh and do modprobe usbtv


#9

Yep i dont check hauppauge drivers, i check only crezycat :slight_smile:

And hauppauge have more drivers and usbtv too, so now device is correctly recognized, and autoloaded modules. But there is another error :), log show we:

[hyperiond V4L2:auto] (INFO) available V4L2 devices:
/dev/video0 usbtv
/dev/video10 amlvideo

[hyperiond V4L2:auto] (INFO) search for usable video devices
[hyperiond V4L2:auto] (INFO) test v4l device: /dev/video0
[hyperiond V4L2:auto] (DEBUG) (V4L2Grabber.cpp:543:init_device()) width=720 height=576
[hyperiond V4L2:auto] (DEBUG) (V4L2Grabber.cpp:557:init_device()) Pixel format=YUYV
[hyperiond V4L2:auto] (INFO) found usable v4l2 device: /dev/video0 (usbtv)
[hyperiond V4L2:auto] (ERROR) start failed (VIDIOC_STREAMON error code 90, Message too long)
[hyperiond V4L2:auto] (WARNING) enable grabber failed
[hyperiond ComponentRegister] (INFO) V4L capture device: off
[hyperiond V4L2:auto] (ERROR) stop grabber, because reading device failed. (VIDIOC_DQBUF error code 22, Invalid argument)
[hyperiond V4L2:auto] (INFO) Stopped


#10

Need dmesg and kodi logs


#11

Hello! Got the same problem (message too long), here the logs: http://ix.io/1kfs


Slow down of Hyperion.ng
#12

Hello again :slight_smile: Is there any news about this issue? External grabber - it’s the last chance for AML-boxes to get ambient light stuff, so its malfunction is very frustrating…


#13

I got also the problem that my video grabber STK1160 is not working after introduction of 8.95.* it seems that simply the driver has been removed.
It worked earlier by loading the haulage driver package.
Is it possible to add that driver again?
I think staying with an 8,94 version is not an option for me.


#14

We have just taken up discussion of this again in the team and have confirmed that this was removed upstream at some point, I have re-enabled it and it should work again in tomorrows nightly image.


#15

Thanks, For the info.


#16

Just tried it with the nightly 20181212 but no success.
I tried it with all 3 dvb driver modules.
Should the driver be in again?


#17

Sorry the change was reverted, @epikurus has been testing it with us as he has an external grabbed, the dvb-latest version of the usbtv module doesn’t work still, there was some success with the kernel version but we need to look into it more.


#18

What is proper internal graber for hyperion on coreelec? Amlgraber does not work for me. Efects are ok.


#19

As @adamg said, I’ve been testing the kernel module and the grabber it’s detected but does not show any input while trying to capture an screenshot. I expect to test it thoroughly during the weekend.

I’m testing it on a S905 device with a Fushicai grabber, so I cannot test STK1160, but If you want to check if it works on yours, here’s a link to an update file with the kernel module based in latest master. S905 only, do not install it in other devices!

https://mega.nz/#!Lj4HUAgI!mBGKoRYzNF49fXZHe5-02-ZgSMzvToOREoD9r9PvCgM

Remember this is a development build, although I’m running it without any problem, things may broke :wink:


#20

I just tried the update I could load the usbtv module but still no device video0.