Hyperion.NG or Hyperion on CoreELEC 9.2.0/Minix U1 + Adalight Arduino Uno +

Hi guys!

After getting nowhere in 3 days I have nothing left but ask for your help. I made my led strip to run with http://ambilight.tender-complex.ru/en/hardware_setup/ this Android app. Everything worked, but Android is huge pain for this task. So I migrated to more stable and efficient CoreELEC.

And after this I’m stuck. Tried Hyperion.NG and Hyperion kodi addons from official repository. Configured it like Adalight, /dev/ttyUSB0, 115.200. Correct led numbers and arrangement. Had to start the service manually via ssh “journalctl -u hyperion.service 2>/dev/null” Hyperion started to answer in web browser. But absolutely nothing happens when video plays :frowning:
How do I diagnose it? May be you can tell me major steps in installing this thing? I’m sure I’m missing something in the process…

You are my only hope.

Deactivate the Hyperion.NG user addons -> services in Kodi and open a SSH connection:
hyperiond --rootPath /storage/.kodi/userdata/addon_data/service.hyperion.ng hyperion.config.json -d

This will give you debug output on the SSH connection and you can search the error.
A config file have to exist:

So Hyperion.NG should be disabled and Hyperion should be enabled? Does Hyperion store it’s config in the rootPath you listed? It’s absolutely where my config is NOT located lol. Let me play with it… THX!

Hyperion is not supported anymore - only Hyperion.NG
Remove Hyperion and install and disable Hyperion.NG

Portisch, thx a million!

Your instructions showed me that Hyperion was not loading the config. I managed to launch it, go to web interface and setup everything there without messing without official Java app.

I was totally not expecting it to start working that good and that fast :slight_smile: Android past is sooooo far behind :slight_smile:
Thx agan. You made my day.


Did I understand correctly that I should install and then disable HyperionNG?
And then what, manually launch it?

Only for debugging!

1 Like

My Hyperion installation worked fine for couple of days after I installed, and then it stopped working. Debug output is:

QObject::connect: Cannot queue arguments of type 'QSerialPort::SerialPortError'
(Make sure 'QSerialPort::SerialPortError' is registered using qRegisterMetaType().)
[hyperiond LEDDEVICE] <ERROR> Unable to open RS232 device (/dev/ttyUSB0)
QThread: Destroyed while thread is still running
terminate called after throwing an instance of 'std::runtime_error'
  what():  Hyperion::getInstance used without call of Hyperion::initInstance before
terminate called recursively
terminate called recursively
Segmentation fault

I would assume there is a problem with my LED interface (esp8266 based), but it works fine, at least I was able to reflash it successfully, meaning usb-com works fine.

Is there anything a I can do from Kodi/CoreElec side to identify the problem?
And yes, the interface is ttyUSB0, I checked it via ls /dev bofore and after the connection.