Inputstream.adaptive.decoder on Odroid-C2

#1

Recently implemented Amazon VOD and it works pretty well

However I’ve noticed in the Player process info screen the following
video decoder: inputstream.adaptive.h264.decoder (sw)

Is hardware decoding not possible? or is there a setting that’s not correct

CoreELEC (official): 9.0.1
Used this repo zip: repository.sandmann79.plugins-1.0.2.zip
And using Inputstream adaptive peak3d-2.3.15.1

0 Likes

#2

HW decoding of DRM content isn’t supported.

0 Likes

#3

Hmm, HBO Go-EU streams are HW decoded at 1080p using inputstream.adaptive and Chromium “libwidevinecdm.so” to work properly…
Are you saying that isn’t DRM content?

0 Likes

#4

I’ve used or been running LE/CE on Odroid-c2 for a while. Using inputstream is all new to me but works pretty good other then apparently supporting software decoding. My question was specific to amazon prime videos

0 Likes

#5

You’re right. Some providers do allow HW decoding, but Prime Video and Netflix don’t, as far as I know.

0 Likes

#6

Worked for a couple of days. Now I’m getting this on two seperate odroid-c2 boxes

2019-04-03 07:30:31.715 T:3277874032 ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.adaptive/
2019-04-03 07:30:36.768 T:3277874032 ERROR: AddOnLog: InputStream Adaptive: Unable to find license;hdcpEnforcementResolutionPixels in JSON string
2019-04-03 07:30:36.768 T:3277874032 ERROR: AddOnLog: InputStream Adaptive: License update not successful (no keys)
2019-04-03 07:30:36.815 T:3277874032 ERROR: AddOnLog: InputStream Adaptive: Initialize failed (SingleSampleDecrypter)
2019-04-03 07:30:36.817 T:3277874032 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.amazon-test/?asin=B07NVVYJNR&mode=PlayVideo&adult=0&name=1±+Mr.+Tequila&trailer=0&selb

Tried this
~/.kodi/userdata/addon_data/script.module.inputstreamhelper directory and delete this file ~/.kodi/cdm/libwidevinecdm.so

And ran the script to install the widev libraries with no success

0 Likes

#7

Auto magically it’s working again

0 Likes