Install to emmc via ssh N2

Hi everyone,

i found a guide on odroid forums showing steps to install CE to emmc on my N2, entirley over ssh. the post is a little old and looks to be pulling an older version on CE.

does anyone know if this method is still possible, and what i would need to update in the url so it pulls nexus 20.2 ng?

wget -O /storage/CoreELEC.img.gz
gunzip /storage/CoreELEC.img.gz
dd if=/storage/CoreELEC.img of=/dev/mmcblk0 bs=1M conv=fsync


nevermind, worked it out

the updated download url for N2 Nexus 20.2 is below… testing the proceedure now :slight_smile:

wget -O /storage/CoreELEC.img.gz


the proceedure works just fine… Sadly it didnt bring back life to my N2 that the USB ports failed on yesterday. updating the emc when attached to my N2+ was fine, but when emc pluged to my N2 with bad USB, while the box comes up, it fails to probe resolutuion from my TV (tried 2 TV’s) so get nothing displayed. SD card slot is also duff on that box, due to phsical damage foolishly clicking the case clsoed with an SD still inserted. been booting of SSD on USB with it for some months untill it stopped sending power out of USB yesterday. Guess when my USB died, so did some other stuff on the board it, so it is the end of the line for this box :frowning:

and just to poke me in the eye, i have flattend the nicley tweeked EmuELEC that i had on the EMC before Grrrrr

Commiserations on your blown USB ports. I have had a similar situation, but it happened the day I got my N2+. However, the OTG USB2 port still works on mine. So, if you get an OTG to USB2 female adapter, you may still be able to connect a USB drive.

thanks for the heads up, maybe i will try some more to get past the failed to probe resolution error so i can actually get it to show something on my TV again! not holding my breath tho. Love the N2 and the + but out of 5 i have owned, 2 failed in some way or other. not to pleased with those numbers. my cheapo old Chinese s905x boxes that are way older and have seen much more service are stilll going strong (slowly lol)

maybe a excuse to start future proofing and get a Khadas VIM4 :smile:

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.