Install to internal problem

Hello @anon88919003, this is only one answer which does make a sense, thanks !

Hey @anon88919003 Here’s my post
Again, not trying to disturb anyone, just found it funny. Thanks.

@gabardal so your post was moved to PM and not deleted, that’s why I couldn’t find it.

1 Like

There is no official support for installtointernal.
That means that devs shouldn’t be offering any support, but the thread is still valid for other users to comment on. Sometimes the devs, in their efforts to help, forget that they aren’t supposed to be offering any advice regarding installtointernal. :wink:

2 Likes

@Poida sorry boss for trying to be helpful

1 Like

For those who want the performance gain from using installtointernal, follow the guide How to boot from SD/USB using internal storage for data so you can take advantage of the increased performance by using internal storage for data. The only difference in performance is mainly the boot time, which is hard to notice and shouldn’t matter. I used installtointernal in the early days with LE, yet after I got to know this method I’ve never looked back. In addition I’ve the option to boot into Android if I want to

1 Like

Ok, I try to ask another question. On the Box is written M96X is a S905X with 8gbrom and 2gb ram. The probla I think is in the flash and is a h27ucg8t2etr of Hynix (http://www.datasheetcafe.com/h27ucg8t2etr-datasheet-64gb-mlc-nand-flash-memory/). DI Ip scanner the manufacturer is ICA Inc. and I do not know who it is. I attach photos.

The problem is that your device uses a raw NAND IC instead a managed EMMC module.
Raw NAND requires that the flash content needs to be managed by the CPU by SW. I doubt that this is supported by CE.

[EDIT] Maybe you can share a pic of the bottomside of the pcb.

Sure. No problem. But now he saw that something is not right. On the device I have 4 ram chips that seem to be from 256bg each for a total of 1GB of ram. However, the system sees about 2GB. Even when I used it with android, it saw 2gb of ram. When purchased it was sold with 2gb ram installed.

You got a box with “fake RAM”.
It really only has 1GB of RAM, and you should be using the 1g DTB on CE.

Ok and why work well the dtb file with 2gb of ram? If i use the dtb with 1gb ram i don’t know if works.

I don’t know why it’s working, but since the box has 1GB of RAM, you shouldn’t use a 2g DTB.

Also I see that on the board there are 4x256mb memories but I do not understand and also coreelec and previus android nougat visualize 2gb of ram.We wait to see if anyone has any ideas about it. I tried two files: gxl_p212_1g_nand.dtb and gxl_p212_1g.dtb but coreelec does not start. It stops at the Amlogic logo.I have attached the file that works.

dtb.img (39.8 KB)

My X92 box works OK with 3 different dtb files…

Maybe they have common features but a 2gb dtb file that works on hardware with 1gb is rather strange. Also because the memory mapping is not performed by the parameters contained in the DTB file but are extracted from the device itself, perhaps in the kernel. I honestly do not know what to really think. If the device really only has 1gb of ram but the dbb file for 1gb does not work I do not see many ways out. As I wrote before, the 1gb db files I tried do not work.

The memory IC is marked 256X16DDR3, no manufacturer, no real chipmarking, so seems to be cheap spotmarket buy.
Anyhow, 256Mbit x16 / 8bit = 512MByte per IC
There are four ICs, so total memory should be 2GByte :+1:

For the Flash, there seems no additional managing IC on the bottomside, so it must be connected directly to the CPU, with some special code in Android for managing it. No chance to get it running with CE :-1:

Anyway, I have the same pèroblema to re-create the message that I can not find a Rome that is compatible with the device. When I upload from usb the upload stops at 4%. I think it’s due to the same problem. One last information .Fing for android sees it as a Minix Player and the manufacturer on the MAC is “ICA”. From a brief search it should be the one on this video:

Finding an Android recovery image for that box may get challenging, I cannot help you on that.

But why don’t you keep the box running CE from SDcard?
As far as I understood, you had CE running. So you just ignore the NAND, and may use gxl_p212_2g.dtb…

This is exactly why install to internal is not recommended. If it breaks it has already trashed your android partitions. When thatb happens you need oneb ROM out of thousands on the net and if it turns out yours is a no name fake clone i wish you luck finding a recovery rom. On top of this most roms are update images which are incomplete for recovery purposes.

Do you wonder why no one will help you dig out of the hole you have fallen into.

DONT DO IT UNLESS YOU KNOW HOW TO RECOVER IN ADVANCE.

2 Likes

It’s what I’m doing. I would like to use CE on nand because it is faster. I can use it like that but it’s not the same thing.

I have to make a clarification. currently the device does not work NOTHING on nand but not because I was wrong something. Simply the device as a result of a power surge has corrupted the data contained in the nand. The nand works but the overvoltage has canceled it. Despite this I can not in any way restore any android rom as during upload it stops at 4%. Currently the only evolution for me is to use it on SD. With this I think I have answered your question.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice