Installation CoreELEC on the Beelink GT-King Pro

I bought a “Beelink GT-King Pro”.
With the device, there was a SD card containing CoreELEC.
But whatever I tried, I could not enter to CoreELEC.

I formatted the SD card, then I downloaded the new CoreElec version and installed it on the SD card using the Rufus software. But after the installation, the SD card will not be seen between other PC drives !!

Again with the Rufus software, I formatted the SD card (after formatting, the SD card is seen between drives) and re-completed the previous steps, but did not have a result.

What do you think is the problem?

No need to format the SD, just install the .tar,gz using Rufus.
Eject the SD and put it back to the PC, copy the dtb and thats it.
If You don´t want to use Rufus, try Etcher

1 Like

Check if only drive letter is missing after writing image.

Looks like using Win32DiskImager and balena Etcher works. But after writing image with Rufus drive letter disappear.

1 Like

Beelink Dual System Coreelec transition.

I copied the “g12b_a311d_beelink_gt_king.dtb” file and changed its name to “dtb.img”.
(I didn’t find a file called “g12b_a311d_beelink_gt_king_pro.dtb”)
This worked and CoreELEC was run.
Thanks Tim

Should use putty and install to internal/ emmc now for a much more stable CE with dual boot, been running this box this way for a few yrs now with great results.

1 Like

I haven’t worked with Putty so far.
How should I use it?

(Off the top of my head) in putty type in your ip address, username is root, password is coreelec. Then type ceemmc -x and hit enter, choose the option to copy contents from sd card in dual boot mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.