Installation on Mecool KM9 Pro

It seems that there are a few boxes
KM9 running 8.1/9.0 Android Skinned
KM9 Pro Classic 2/16 running 9 ATV
KM9 Pro Deluxe 4/32 running 9 ATV + AC/Gig
KM3 4/64 or 4/128 running 9 ATV + AC/Gig

The latter 3 seem to be Google Certified (ie. Run proper AndroidTV) but not Netflix/WV3 but also bootable via reset into CoreElec on SD.

I have as well KM9 PRO 4/32 Android TV 9.0 with working Chromecast and some DRM and I can run CE without problem.

Is your remote slow with press after enter ssh command and cant power on device?

Is there a way to select Autoboot Android or CE with removing the SD Card?

Hi, I have a km9 pro and I can’t start coreelec, what device tree do I have to use? thanks


¡gracias! this afternoon I will do it when I leave work and I will put here the results

Great. It works very well for me. I just can’t be bothered to remap the original remote as I use another.

If you get it working properly post the config :grin:

Hi all,

I’m having problems installing CoreELEC on MECOOL KM9 Pro (s905x2, 4gb). I use g12a_s905x2_4g.dtb. Have also tried g12a_s905x2_2g.dtb, just in case.

When I insert the SD card and boot with the “Toothpick method” I get the MECOOl (“TV Box”) splash screen after which I get a complete black screen. I get the same “error” when I simply boot with the SD card inserted (not using the toothpick). The CoreELEC logo never appear. I have succesfully booted in android recovery using “Toothpick method”.

I’m not able to run ‘reboot update’. In Termux I get ‘unknown command’. In Qute Terminal I get ‘permission denied’. I’m in developer mode as well.

Any ideas on how to solve this?

It seems that others have been able to install CoreELEC e.g. Installation on Mecool KM9 Pro

My setup:
MECOOL KM9 Pro (s905x2, 4gb)
Android 9, Google Certificated Voice Control Android TV Box
Burned CoreELEC using Rufus onto SanDisk Mirco SD HC 8GB (previously used on LibreElec with Raspberry Pi).
Tried two different HDMI cables, both work when booting into android.

Check the Android version on your KM9 Pro.
The Freasktab link you posted shows the Android Version in this picture

This guy on the same forum has issues with updated Android


I have the exact same version as on the picture you link - not Android 10. Sorry if I misunderstand your reply, but as I understand it, the folks in the Freasktab topic only experience problems with Android 10, not version 9? Seems like ‘andymarc’ actually had CoreELEC working on Android 9, but that it broke when he update to Android 10? (I know that you can answer for him, just trying to figure things out).

I haven’t been able to find any help on installing CoreELEC in the Freasktab topic. Maybe I’m missing something?

Eliminate this SD Card and try a more updated SD Card or try USB stick.

I only just noticed the SD Card you are using.

Some SD Cards can cause issues with booting.

Will do. Is there difference in speeds when using a USB (KM9pro got usb 3.0)? Is it slower?

Ok so I tried two different USB sticks - one USB 2.0, one USB 3.0. Using the g12a_s905x2_2g.dtb (figured out that it is the 2gb box that I have). Same error. Also tried to format the sticks from two different USB ports in my computer. No luck with this method either :frowning:

I’m not sure what you can do without UART log.
No other way to debug what’s happening on boot.