Installation to eMMC with ceemmc tool and booting other OS

quick question… can someone tell me or point me to where I can read more about it, but what does ceemmc do exactly to the device that stops it from booting other OS? my s905x3 won’t boot to armbian SD anymore.

ceemmc doesn’t do anything special regarding booting and it follows the same boot path as before. It only adds booting of CE from eMMC AFTER trying to boot from uSD card or USB stick. That’s why box should always boot to some recovery even if system from eMMC doesn’t boot for some reason.

iSlaker, using reset button should clear things up. If it doesn’t it must be something else and it it not because of ceemmc.

If you put CE sd card and use reset button does it boot from sd card?

@Shoog and @vpeter

I don’t know how I can be more clear. It’s as if the box is expecting to find CE and won’t take anything else.

  1. The reset button does NOTHING.
  2. I CANNOT restore the stock firmware because it WON’T load the SD card with it anymore.
  3. The ONLY, truly ONLY thing that boots is CoreELEC. It can be on a USB stick, it can be on an SD card or even in the eMMC. It is ONLY CoreELEC and absolutely NOTHING else!

Do you have CE SD card or USB stick attached when using reset button?

If I boot the box with CE on a USB stick, it’ll load CE from the USB stick. Regardless of the reset button being pushed down or not. Same thing if an SD card with CE was inserted.

If I boot the box with the shall-not-be-named OS then it will boot the CE that’s in the eMMC - AGAIN - whether the reset button is pressed or not.

If I boot the box with the restoration SD card inserted then it will boot to CE from the eMMC - ALSO - whether the reset button is pressed or not.

Realistically, the fact that CoreELEC runs successfully means that the key aims of CE have been met.

The issues being experienced are to do with other solutions that have no direct connection to CE.

The standard piece of information regarding the reset button has been given and as you say, that does not seem to work.

So the next logical step, apart from wait and see if anybody on here comes up with some more ideas, is to contact the developer of the Armbian release and ask the same questions of them.

I’m guessing that you probably downloaded Armbian from a site which the dev has presence and I know that one of them is Freaktab and the other is another site ending with ELEC.

I do not know what specific issues there are, or have been between ‘teams’ on different sites that went in different directions, so I don’t have any specific axes to grind but I have followed the progress of both and I can say that the other developer has given out false information regarding the requirements of having to use the usb burning tool to flash a stock rom in order to resolve issues and that I’m afraid does throw up a little red flag.

So follow 2 paths, 1, of keeping an eye out here for further suggestions and ideas and 2. track down the forum/support site that the other developer frequents in order to get some help there too. Regardless of what individuals may feel about each other, there is always a wider community that are not deeply involved in and have no knowledge of conflicts that will throw in their thoughts and ideas when they have them.

If system boots from sd card or usb stick then everything is just as was before. As I wrote only change done by ceemmc is possibility to boot from emmc AFTER sd/usb. I don’t understand why in your case something bad happen. Did you check with fresh Armbian SD card?

I did Android reinstall from SD card few times and it always worked fine. With CE installed on emmc.

Maybe your box is just something special. Which one is it? Maye I missed this info.

I suspect that the Armbian system has overwritten the standard bootloader and this is what got copied over to the emmc when ceemmc was run. The reason that it won’t boot from the SD is because the Armbian bootloader which is now on emmc is telling the system to only boot from emmc.
Thats just a guess though, but if its correct then the only way back is to reburn an Android image.


Shoog: but he can boot from SD card and USB stick. But only CE on it.

No, as I see it he can only boot CE from eMMC which has Armbian u-boot…

No, I can boot CE from anywhere. Literally anywhere.
The point is that CE is also literally the ONLY thing that I can boot at all.

@vpeter: So did I. This is not my first box.

At this point I don’t even care about Armbian anymore. And every time I type its name I feel like I’m calling Voldemort or something. All I want is to be able to restore the stock firmware. That’s all.

Would this box still have a Recovery menu/mode? If so, how can I access it? The box is an X96 Max Plus with S905X3.

@Shoog: So you’re saying that all those times I ran the shall-not-be-named OS off of an SD card it was affecting the bootloader? Even though I’d take it out, put the one with CoreELEC back in, or boot into the stock firmware just fine? How’s that possible?

Armbian may be part of things though because that is something that you reported as not working after using ceemmc.

Sometimes strange things can happen that may seem to or not to involve something that is part of the process being reported, so it’s always useful to use a belt and braces approach and ask everybody that might have some key input that could resolve the issue.

Normally boot CE and open ssh session. Type command

fw_printenv | paste

and post link you get. Then type this two commands

fw_setenv upgrade_step 3

Maybe then you will have more luck running other systems from external media.

After you had a working version of CE on eMMC, how did you start Armbian from an uSD card? If with toothpick method then it’s possible…

Once CoreELEC got onto eMMC, NOTHING has been able to boot except CoreELEC.

Did you tried commands I wrote above?

1 Like

I did, yes. Ever since you suggested it I’ve been trying with different combinations of media and pressed/not pressed reset button scenarios but so far it always ends on CE.

Another thing that I’ve been wondering is that in a previous box I also ended up stuck and I had opened it to short some pins to get it into a mode that a USB-A to USB-A cable would work and Windows would “see” the box. Does anyone know if the S905X3 chipset needs that as well? How can I access the Recovery mode or recovery menu?