Installing Corelec on Mecool KM6 Classic / Deluxe

Hello, how to install Coreelec on Mecool KM6 Classic? I have already unlocked the bootloader, installed root access, written the image to a USB flash drive following the instructions, and used sc2_s905x4_2g.dtb, but the device refuses to reboot into Coreelec. I have tried all available methods, but the device simply restarts into recovery mode. I tried all 2 usb connectors, but to no avail.
Here is the available information on the device:


It seems to only come with 4Gb so that dtb is wrong. Looks a nice box with wifi 6 but Mecool is not officially supported. How are you booting, on the km5 I think I had to hold down the power button, successfully got that running coreelec but no dbs.

1 Like

Classic - 2/16 - 100M LAN + wifi 5, Deluxe - 4/32 - 1000M LAN + wifi 6. Pressing the power button did not help. I probably need to try installing the firmware from a third-party device to use a different bootloader for Coreelec.

Yes
Or maybe upgrade to Android 11
Downgrade to Android 9

There was issues with CoreELEC and Android 10 vendor.

At least my A95XF4 with Factory Android 10
CoreELEC would not boot.
No matter what was tried
Had to flash Android 11 3rd party for success

1 Like

I’ve tried many different firmware, including android 11 from A95XF4. CoreELEC started working after flashing this SC-Tanix_X4-S905X4_DEBUG-NORMAL-v1.0_20220615, but Wi-Fi and bluetooth are not working. Probably there are no necessary drivers.
upd.
Firmwares for KM6 “Classic” and “Deluxe” for further launching CoreELEC:
Unofficial firmware for KM6 Classic - SBX — Яндекс Диск
Unofficial firmware for KM6 Deluxe - ATV_X96_X4_Pro1_20220305-1204.7z - Google Drive

You are success then !!

Of course you will need a usb device to navigate
I have Logitech K 400+ Keyboard

Which version CoreELEC?

Support for wifi/bluetooth varies with kernel

Also there is a Thread

Looking for Users with No Working Wifi/Bluetooth

In discussion Threads about .ne .no .ng

1 Like

I just checked three versions: CoreELEC-Amlogic-ne.aarch64-20.3-Nexus-Generic, CoreELEC-Amlogic-ng.arm-20.3-Nexus-Generic, CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240209-Generic. NE - bluetooth and wifi are not working. NG and NO - only bluetooth does not work. Thanks for the hint where to contact about this problem.

1 Like

Hello, i didn’t reach to recovery mode because my KM6 classic is in a bootloop.
I didn’t find any reset button. Do anyone can help me going to recovery mode please ?

The reset button is located inside the AV connector (3.5mm jack). Hold down the button before turning on the device.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.