Installing on a Venz V10 S905 1GB 100M ethernet


#1

I managed to acquire on of these really cheap but it’s only cheap if it works. It’s S905 I thought so it must load CoreElec. I was wrong. It will not boot from SD card. It seems that the aml autoscript doesn’t work because the box hangs on the Amlogic S905 logo when the sd card is inserted on boot.

The manufacturer does provide a zip file that changes it from android to XXXXElec kodi 17.3 but this is sadly lacking (none of the network improvements, no docker and it’s not leia).

Before I give up on this, can I just ask if anyone has any suggestions about getting it to run CoreElec? I don’t expect that there’s going to be anything but I’d be delighted if someone could come up with the answer. Thanks for reading.


#2

If your box hangs on the Amlogic logo then it is not the aml autoscript, it is that your using the wrong dtb.


#3

Thanks for the response Adam.

I’ve tried the 2 gxbb-p200-1g-100M dtbs (with and without realtek wifi) to no avail. Also tried the dtb.img from the venz version of XXXXXElec and unsurprisingly that doesn’t work.

In checking the dtb names I noticed that the Android zip file for this box is p211-ota-20181214.zip. In your dtbs there are P200 P201 P212 etc but no P211.

Am I chasing a dtb that doesn’t exist?


#4

I would try a p212 variant. I see several versions of the V10 that actually have the s905X instead of s905.


#5

Thank you Jaaxx, you nailed it. I tried gxl_p212_1g.dtb first and, bingo, it boots with both wifi and ethernet.

I was about to give up on it and am really grateful for the support and to the developers of CoreElec.


#6

This device is added to the download helper, now.