Installing to internal NAND/eMMC

@blademan yes when it comes to SBC’s, we do help with issues with those.

  1. They was designed with this purpose in mind, ie. installing different OS’s to the eMMC
  2. They are easy to recover
  3. Many members of the team have the devices to be able to offer support

None of the above apply to Chinese Android TV boxes and as such that is why we do not help with issues that occur on these devices due to installtointernal.

2 Likes

Just FYI, installtointernal works perfectly 2nd time with Tronsmart Vega Telos.

Not a huge speed increase on Kodi, but I was using a Sandisk Ultra Extreme SD card which is very quick anyway.

I have Venz V10 Pro, officially comes with android 6 or 7 fw. There is also official Venz dualboot Librelec 8.0.2/Android 6 FW, which I have been using for sime time. I almost never botted into or used Android and decided to try Corelec 9.0.1 instead of LibreElec 8.0.2 (Kodi 17.3). I was satisfied with LibreElec it worked really great. After trying CoreElec 9.0.1 from SD card for a few days, which worked great, I decided to installtointernal cause I really don’t need Android, and thought I might be proficient enough to recover original firmware if I somehow managed to brick it. It went smoothly, installtointernal worked great for me. Scanning and refreshing libraries seems much faster.

My device uses Amlogic SOC S905X, it has 2/16 GB internal memory, and I used gxl_p212_2g DTB image.

Please don’t take this as encouragement, I’m describing my experience with specific device but it may not be the same for you. Take care and caution if you decide to install to internal, and be sure that you can restore your device into working conditions if anything goes wrong, before you attempt any of it.

Welcome to CE and your first post.:wink:

Go over to ❓ Which DTB do I use?
and disclose your device and DTB.IMG you used to successfully boot CE.

1 Like

hello, my Mecool KIII Pro (S912) is running fine with coreelec 9.0.1 from microsd card with gxm_q200_k3_pro.dtb

but after running “installtointernal” two times without errors, it hangs at the boot logo. it still can only start with the microsd card.

what could the reason?

…fixed


Is that the CE Boot Logo ??
Or the Android Boot logo ???

I have installed CE in my Odroid N2 flashing a sd card samsung evo 32gb.
Is there any advantage in flashing an emmc with the same CE version?
And, if yes, what should I do for flashing it? Any different method compared to sd flash? Any difference for booting or is it just the same as for my present sd installation?
Of course I should by a emmc for N2 I suppose or those for C2 are ok also?
I apologise for questions that you may consider almost silly, but I am completely out of technicism with very little experience.
Thanks for help

The emmc is faster than a micro sd card.
There are some issues that occurs only if you running CE from card.
You can write the CE image to your emmc with a micro sd adapter or usb emmc writer or inside the N2 from a micro sd card using installtoemmc script.

Let us know if you notice the difference in speed when you install to emmc.
I’m interested as i have CE running on the Samsung Evo SD Card and it’s lightning fast.
Faster than any other Box I own. Faster than CE installed to internal on these other boxes as well.

The Suspend Mode using the Samsung SD Cards is solved. It works for me. Don’t think I’ve seen anyone reporting issues lately.

I started using N2 with fast sandisk card and I thought it is fast. Then put the emmc and it updates faster.
I had CEC issue after suspend or update with sd card which is not present with emmc.

The emmc on the Vim2 is significantly fast than any of the SD cards.

Shoog

I have ordered from Korea the emmc card 32gb, the micro sd adapter and the usb emmc writer.
Which software should I use to write CE on the emmc using the usb emmc writer?
Thanks again.

This is not a like-for-like test. The Sandisk card you are using is a very old card, not even a U1 card.

Anyway the Sandisk Extreme / Extreme Plus / Extreme Pro U3 cards are very cheap now and are noticably faster than the U1 cards.

You can use Etcher. Very easy to use and available on Windows, Mac & Linux.

Thank you. Will report after the emmc arrives.

I don’t get it what you want to tell me…

How embarrassing . You’re right. :laughing:
I just pulled out the Sandisk to have a look.
Thanks for pointing that out.

Don’t worry about it. I was testing a Sandisk Card that belongs in a Museum.

1 Like

I just grabbed one of my old Sandisk U1 cards to compare like-for like and the results were pretty similar to the Samsung U1. 19.5 Read (slightly faster), 14.2 write (slightly slower)

I’ve got an Odroid-N2 and a Le Potato board on order where installing to eMMC is supported.

Does the eMMC module have to be configured first or does the script handle all that?

Can the image be written to the eMMC module with a USB writer similar to the way the SD card is written?