Installing to internal NAND/eMMC

Either stirp it from Coreelec or make it working. If not working and there is no any idea how to make it working, better to remove, at least for devices confirmed not working. On MXQ Pro: I tried with libreelec and it bricked the box, now on coreelec I am getting nothing more than error message saying my device has no internal memory.

BTW I was aware about the risk, but I did not plan to use built in Android system either, so brick is not any big deal as long as I am able to boot Core/Libreelec from sd card.

Yours is an old device by these boxes standards and possibly that means it was released before the introduction of dtb,s. If thats the case then it could never work and you would need to find a packaged version of Libreelec which was designed specifically for your box. Its a lot more involved a process and requires more work on your part assuming you can find such a version.

But it bares repeating this feature is not advertised, not recommended and not supported. If you can’t get your box back its your own responsibility. Removing it for everyone else who can handle it would be unfair, and your complaints are likely to end in it been removed from us which would be a shame to say the least.

Shoog

2 Likes

I don’t get it. I need to choose right dtb file to boot from sdcard. So, dtb files support is there. Problem is somewhere else, perhaps dtb is not copied properly to internal memory and this is why box refused to boot. Box is S905X, it works the same as others on this soc.

@giaur500
Do not try to look for guilt in the Coreelec team for your unsuccessful installtointernal procedure!!!
All of us know that if something goes wrong you can brick your device, and then nobody is responsible for this brick.So…my experience shows that you can always restore your device back to stock Android firmware and then to try installtointernal again.If you are in interesting how to do that just check freaktab forum.Do not wait for help here.My advice is:first try to find your original Android firmware.Second:install USB Burning tool and try to reflash your device.If you have some problem I can help you to do this.

1 Like

Why do you think I’m looking for guilt? I even said I was aware, but I also don’t care about Android firmware, because it’s useless for me

Simply because you moved a dtb into the root folder - doesn’t mean Coreelec ever used it. I feel certain that the bit of digging I have done on this box places it before the advent of dtb’s. People are using TWRP on these boxes which points to the old method.
Your pathway to a working box is :slight_smile:
-find your original Android ROM
-reburn your android rom using AMLogic burn tool
-find a copy of TWRP which is designed for your specific box and burn it using what whatever instructions it comes with
-find a version of Libreelec packaged for your box and use TWRP to burn it to your box

A good place to start would be plouging through this Freaktabs thread:

Or try this thread which specifically outlines the procedure I described:

Be warned, when I found myself in a similar situation to this with my S812 box it took me weeks of hard work to get it back up and running. However I now still have this running a Krypton build so it was worth the weeks of effort it took (maybe).

Don’t come back asking questions till you have consumed this information in enough detail to try it yourself.

Shoog

Please, never remove installtointernal script. Most of these cheap - and not so cheap - boxes totally mess up HDMI-CEC and the only way to fix that is to install CoreElec to internal memory. I have tried (according to my wife, too) many of these Android devices and every single one of them completely f**** up everything connected to my Sony soundbase. No matter if the HDMI-CEC option is disabled on the device or not, even my TV can’t connect to soundbase if I leave these Android boxes connected.

So please leave it as it is for us thankful users to run on our own responsibility.

1 Like

Hi,

I was using Libreelec for the last 2 years on a RasPi2 but was facing stability issues since the Kodi 18 versions … the WAF dropped dramatically :stuck_out_tongue_winking_eye:

I got the advice to check CoreElec on a Amlogic device, so I’ve ordered the Magicsee N5 which arrived today. Because I never ever will use this Android crap and need a pure Kodi box, I’ve issued the installtointernal script after booting from a USB flash drive.

I know it’s not officially supported but I have a short question to the guys who already have used it: How long does the “Writing device tree image” step run?

I see in the script there are two “dd” commands and I know even from my powerful servers that dd can be freakin’ slow. The dd process is running now for 83 minutes … how much do I expect in this step?

Thanks,
Marco

No support means no support sorry, you run it at your own risk, we will help with any other issue.

@adamg Ahm, I’m not really crying for support :wink: I just want to know how long it’s worth waiting for it before digging out the AMLogic USB Burn tool from the experience of the users who already ran it successfully :grin:

It usually takes a few mins so I would say something has gone wrong.
Was it running successfully off of SD before you attempted install to internal ?
Have you issued the command “installtointernal;” twice - the second time after a reboot as this is sometimes necessary.

Shoog

1 Like

After burning to usb, did you wait, & check that coreelec was running ok, before running the install command.

After waiting so long, I guess it’s Tom tucked

Thanks, guys! I’ve quit and did a reboot from USB drive, it’s running a second time. I’ll see how it goes, otherwise I’ll burn an SD for it.

I don’t know if we are allowed to help with installtointernal, but one of my boxes is N5 and I forgot to copy the device tree to root of sd before running installtointernal and it got stuck in the writing device tree process. So just copy the correct device tree from device tree folder to sd root, rename, and try again.

2 Likes

Users are allowed to help, ofcourse. Only don’t expect any help/support from developers.

1 Like

Just to understand, I have an Odroid C2 and want to use eMMC. Is this supported?

@mx77 Yeah, that was the issue. As I was asked while downloading for my device I thought the device tree file was already the correct one. It wan’t. :wink:

Copied the right one over and it worked within seconds!

@blademan yes when it comes to SBC’s, we do help with issues with those.

  1. They was designed with this purpose in mind, ie. installing different OS’s to the eMMC
  2. They are easy to recover
  3. Many members of the team have the devices to be able to offer support

None of the above apply to Chinese Android TV boxes and as such that is why we do not help with issues that occur on these devices due to installtointernal.

2 Likes

Just FYI, installtointernal works perfectly 2nd time with Tronsmart Vega Telos.

Not a huge speed increase on Kodi, but I was using a Sandisk Ultra Extreme SD card which is very quick anyway.

I have Venz V10 Pro, officially comes with android 6 or 7 fw. There is also official Venz dualboot Librelec 8.0.2/Android 6 FW, which I have been using for sime time. I almost never botted into or used Android and decided to try Corelec 9.0.1 instead of LibreElec 8.0.2 (Kodi 17.3). I was satisfied with LibreElec it worked really great. After trying CoreElec 9.0.1 from SD card for a few days, which worked great, I decided to installtointernal cause I really don’t need Android, and thought I might be proficient enough to recover original firmware if I somehow managed to brick it. It went smoothly, installtointernal worked great for me. Scanning and refreshing libraries seems much faster.

My device uses Amlogic SOC S905X, it has 2/16 GB internal memory, and I used gxl_p212_2g DTB image.

Please don’t take this as encouragement, I’m describing my experience with specific device but it may not be the same for you. Take care and caution if you decide to install to internal, and be sure that you can restore your device into working conditions if anything goes wrong, before you attempt any of it.