Installtointernal on Tanix TX3 Mini H 2gb/16gb s905w partitions missing

Hi!
I’m booting CoreELEC from sd card on this box. CoreELEC is working nicely from sd card using gxl_p281_2g.dtb. But when i start installtointernal through ssh i get this error:

    CoreELEC:~ # installtointernal
One of BOOT, SYTEM, DATA or DTB partitions is missing.
Make sure that you are using a correct device tree and a device with internal memory!

Not all devices are compatible with installtointernal due to unsupported NAND/eMMC
chips being used by some manufacturers.

blkid gives me this

CoreELEC:~ # blkid
/dev/loop0: TYPE="squashfs"
/dev/mmcblk0: PTUUID="04f4c3d9" PTTYPE="dos"
/dev/mmcblk0p1: SEC_TYPE="msdos" LABEL_FATBOOT="COREELEC" LABEL="COREELEC" UUID="2911-4327" TYPE="vfat" PARTUUID="04f4c3d9-01"
/dev/mmcblk0p2: LABEL="STORAGE" UUID="efc403a6-5657-4842-a54f-b5ae9afa42ad" TYPE="ext4" PARTUUID="04f4c3d9-02"

If I understand correctly CoreELEC doesn’t see internal memory of the box and that’s why installtointernal doesn’t work. gxl_p281_2g.dtb is a right dtb for this box but when I decompile CoreELEC one and the original one to .dts there are some differences (seen in Meld), especially in partitions section. I tried to switch original dtb with CoreELEC one but it wont boot. Does someone know how to make a new dtb from the original one that is specific to my device but to work with CoreELEC. I’ll attach both .dts in .txt format.

dtsce.txt (47.8 KB) dtsoriginal.txt (48.0 KB)

There is no support, because it´s a bad idea

Reinstall original android firmware IMG

I did. Android boots if I pull sd card out.

I always followed the following steps:

  • clean android firmware installation with USB cable
  • root enabled on android firmware
  • restart with the app ‘Reboot to LibreELEC’ from Play Store
  • boot CoreeLEC from the flash card
  • SSH access configuration in CoreELEC
  • installtointernal command (2 or 3 times if it fails)
  • CoreELEC boot from internal memory
  • reinstall/update CoreELEC firmware in internal memory from tar file

Note:

  • flash card access speed ~ 10 MB/s (and does not support any USB hard drive at boot)
  • internal memory access speed ~ 200 MB/s (and supports all USB hard drives you need at boot)
  • USB hard drive access speed ~ 35 MB/s (and does not support a second USB hard drive at boot)

(tested on TV Box S912: Mecool KIII Pro, H96 Pro+, and my very old Acemax M12N)

installtointernal is only working if NAND/eMMC is recognized by CE.
There are many cheap boxes with very cheap NAND which is recognized.
There are many reasons why CE devs don´t support installtointernal.

Remember Forrest Gump
“Stupid is as stupid does”

1 Like

I do it exactly the same way but it just doesn’t recognize internal memory for some reason.

Are you saying that installtointernal is not depended at all on dtb file, but only on CoreELEC itself?

It has nothing to do with the device tree.

@Tim_Taylor was bang on point, your eMMC/NAND chip is not supported by our kernel.

Nothing can be done in this scenario.

Why ?
Is there any important reason ?
don´t beleave the fairy tale -> huge speed increase/box is running 10 times faster etc.

Just to add 2 cents here, I have used installtointernal on this box type, and had to perform the installtointernal twice to get the partitions right (just to see if it worked), but there seem to be several variants out there.

However speed difference between internal memory and a good SD card (32 GB Samsung Evo Plus) is not noticeable in daily use.

sure Your box have the same NAND ?
I´m not :face_with_raised_eyebrow:

So, it’s not supported by the kernel… Alright. Thank you. Guess thats why “Reboot to emmc” never worked and has disappeared with latest updates.

@Tim_Taylor
Low transfer speed prevents usage of Elementum addon. Gives “Source too slow” error when download location is set on sd and not just streaming on RAM. SD is too slow I guess. Other things work ok. Seems to me kinda silly to use external cards when perfectly good 16gb emmc just lies there, doing nothing.

@Sentry23 I can do it a thousand times and nothing…

OK
I´m out
Elementum addon is blacklisted by team kodi

Elementum has nothing to do with installtointernal script but I guess I wont be able to transfer CoreELEC to emmc anyway since you don’t support the script itself. It would be nice to be able to boot Android then, since it’s there, on emmc. I’ll open another thread regarding this problem to keep it clean. Thanks for the replies!

We wont help you with anything if your engaged in piracy, period!

Topic closed.