IPTV Simple Client issues?

Today, out of the blue,I noticed that all my iptv channels load for a veery long time and when they finally do they play with a timeshift. It has never happened before. I’ve tried different Coreelec versions (even Matrix) which previously worked fine but the same thing happens? Is something wrong with IPTV Simple Client addon?

Or is it your provider? Or network. Or …

Channels(from the same provider) work fine on my mobile connected to the same home network. Very strange. I’m stumped as coreelec with IPTV client has always been the most stable and issue free option in my case.

It looks like sth has happened to my Odroid C4’s LAN port - Speed Tester shows Ping over 2000 and DL speed is only about 10Mbit. I’ve just tried Kodi on my laptop and there my IPTV works flawlessly.

Or is it dtb’s fault? But I guess for Odroid C4 it gets picked up automatically…
Until yesterday everything was OK but then I installed yesterday’s Nexus version and it got like that.

No idea why but installing Android for Odroid C4 fixed the problem with slow DL speeds and now I’m back to Coreelec. Before that I’ve tried different versions of Coreelec and Libreelec and they all were slow with DL.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.