IPTV Simple Client: URL format playlist does not work in CE

I am using the m3u url in the following formats:

[MPEGTS]
http://host.com:4300/mpg/user:pass:playlist.m3u

[SIPTV]
http://host.com:4300/siptv/user:pass:playlist.m3u

The unusual thing is that using Kodi on Windows it works fine, but when using the same m3u url on Kodi on CE it cannot load the channel list. Could this have something to do with the ‘:’ character within the m3u!

I have already forgotten what to give before / after “:”.

Thnx

I tried to add : character in my list and correct url come to server.

Are you sure it is
http://host.com:4300/siptv/user:pass:playlist.m3u
and not
http://host.com:4300/siptv/user/pass/playlist.m3u

Yes it’s right and it doesn’t work.
I use this: https://nice-panel.com/restreamer.html
I can provide a link to the playlist via PM

A similar problem, maybe a Linux problem?

Sure, send me something on PM and I will try to repeat the problem. It is much easier like this instead of guessing what is wrong :smiley:

send pm…thnx

Got it working (partially).

The problem is that libcurl supports http/2 protocol and offer this with http header Upgrade: h2c.
Servers not supporting it should just ignore the header but seems server used here doesn’t upgrade connection but also doesn’t return any data. So the problem is not character : (btw it works also encoded with %3a) but the server used.

The solution in Kodi Matrix is to disable http2 support with network/disablehttp2 in advancedsettings.xml.
Not sure if this is possible in Kodi Leia build with http2 support (without making own CoreELEC image).

CoreELEC:~/ # more /storage/.kodi/userdata/advancedsettings.xml

  <network>
    <disablehttp2>1</disablehttp2>
  </network>

Maybe there is some option in the server.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice