IPv6 settings

#1

Trying to set up IPv6 on my boxes after enable i put the adress in place and then save. When checking nothing gets changed and ipv6 is disabled

/Henrik

#2

You need to add file for example /etc/sysctl.d/ipv6.conf
with content (modify if you use another then eth0 interface):

net.ipv6.conf.all.disable_ipv6 = 0
net.ipv6.conf.default.disable_ipv6 = 0
net.ipv6.conf.eth0.disable_ipv6 = 0

and execute as root:
systemctl restart systemd-sysctl

Now you have ipv6 on your CoreElec.

I also managed to enable it on tvheadend by modifying /storage/.kodi/addons/service.tvheadend42/bin/tvheadend42.start file in line 147 by adding -6:

TVHEADEND_ARG="-6 -B -C -u root -g video -c $ADDON_HOME $AVM_SATIP $CUSTOM_ARGS"

Unfortunately my client doesnt support ipv6 :frowning:

#3

Thanks
So IPv6 is disabled by default

/ Henrik

#4

Yes, I also discovered that you need to add:
/usr/bin/systemctl restart systemd-sysctl
to .config/autostart.sh to keep it after reboot.

I don’t know why it is disabled by default but in my opinion it should not be.