Is it possible to create a symlink in /usr/bin?


I’s using rclone installed “manually” at:

Using this version:

So, I have in the folder:

the files:
rclone.conf (with all my “remotes”)

I have used rclone during some years in this way, without any problem at all.
I “updated” rclone “manually” a lot of times changing old
binaries with new ones. The last ones are:
1.62.2 version

I have ~ 10 remotes configured, and I use the same “rclone.conf” with 4 different TV-boxes (S905X3, Amlogic-ng; CoreELEC 20.1).

Well… rclone 1.62.2 version DOES NOT WORK, and I had to return to 1.61.1 to get rclone working and mouting the virtual drives again.

It seems that there is a problem with “fusermount3”:

that is a file that new rclone 1.62.2 needs to mount the drives, and that seems that is NOT been used with CoreELEC.

I tried to install:
and now I have a:

file, but it seems that is not enough for rclone 1.62.2, because rclone must search only in:

So, I tried to symlink it in both ways:
ln -s /storage/.opt/bin/fusermount3 /bin/fusermount3
ln -s /usr/bin/fusermount /usr/bin/fusermount3

“Read-only file system”, so I could NOT create the symlink for fusermount3.

So, finally, the questions:
1) Is there any way to “symlink” fusermount3 to /usr/bin?
2) Is possible to add fusermount3 to next CoreELEC versions?

Thanks in advance and kind regards

No and no.

Why not using rclone from entware?

If there is no alternative, I would do that.

Perhaps in next rclone versions a backward compatibility with “fusermount” is implemented… or not.

If not, I would follow the proverb: “If the mountain does not go to you, you have to go to the mountain” :rofl:


Thanks to ncw ( )

I finally got it using CoreELEC:

  1. The latest version of rclone ( ; at this moment, 1.62.2) “installed” (uncompressed binary) and with executable permissions:

  2. Installed fuse3-utils via entware:
    opkg install fuse3-utils

It goes to:

  1. Created rclone “services” like this:

Description=RClone Gdrive
ExecStartPre=/bin/mkdir -p /var/media/Gdrive
ExecStartPre=/bin/mkdir -p /storage/.config/rclone/logs
ExecStartPre=/bin/mkdir -p /storage/.config/rclone/cache
ExecStart=/storage/.config/rclone/rclone mount
--log-file /storage/.config/rclone/logs/rclonemount.log
--log-level INFO
--tpslimit 10
--tpslimit-burst 10
--cache-dir /storage/.config/rclone/cache
Gdrive: /var/media/Gdrive
ExecStop=/bin/fusermount -uz /var/media/Gdrive

I needed to add:
in the PATH:

And it works perfectly!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.