Is it possible to set RGB low mode (0-255) on the N2?

I noticed there is no toggle in corelec (march 25 build) for the n2. Has this been removed from kodi all together? My apple tv 4k has a “rgb low” (0-255) and “rgb high” (16-235) . When I set it to rgb low, the blacks get much darker, and colors deeper. As it stands, my N2 appears as if its set to yuv or rgb high, as colors appear faded in comparison to the rgb low setting on my apple tv. Additionally, my TV has an rgb mode which is set to “on” , which then allows the apple tv to take advantage of rgb low.

Is there a way to change the output in similar fashion with corelec / odroid n2? Or am I stuck with the way it looks?

Kodis own website goes into much detail about color space , but the documentation is kodi 16 era. The setting it is discussing (0-255) does not appear in corelec on my n2, nor does it in kodi 18 on my phone.

Any help would be appreciated!


Try to turn off rgb mode on your tv.

Most of the info on the kodi website is out of date and x86 specific.

99% of video content in general will be encoded for limited range what you refer to as “rgb high”, so there is actually no advantage to changing the colour range for a TV. TV’s and computer monitors handle colour range slightly different from each other, hence the two colour range options. TVs generally only have an adjust colour range option to correct for computers that don’t realize the TV is not a standard computer monitor.

At some point In the future I may add colour range controls to CoreELEC on the N2 to help people who use the N2 with a computer monitor or that just want more settings to play with. :grinning: This won’t be in the immediate future however, since there are a lot of other things that need attention first.

In the mean time @Pelican’s suggestion of adjusting the rgb mode on the TV should correct things for you.

I will test this as soon as I get home, and get back to you with how it looks.

I would love to have the deep deep blacks , and popping colors as is on my apple tv (rgb low on apple tv + rgb mode on tv) .

The “correct” way to watch most video content is in “limited” range, which you refer to as “rgb high”.
So instead of configuring your TV properly, you configured your ATV improperly.
It’s best to set the TV into RGB High mode, and enjoy your viewing experience with the N2.

1 Like

My tv has two settings. Rgb / yuv / auto.

I tried every combination. The color issue I should have clarified was in fact fixed! Setting my tv to yuv resulted in deeper colors and darker blacks on my n2 (when compared to rgb mode on on my tv with the n2).

So thank you for helping with that.

This other issue I am now describing is not the same issue. It has to do with picture sharpness - ie how close it looks to real live tv on a modern cable box (as opposed to a stream watched on a pc) - when discussing : motion (tested with soccer ball) / edge sharpness / degredation etc.

Degredation “boxes” (few pixels only are visible on n2 playback. They are ever so slight - look at the edge of a soccerplayers shorts with the green grass during motion - Wheras apple tv /fire tv has no such behavior, its almost blurred out. The “edges” of the degredation are more crisp or visible on the n2 basically.

If I had a high quality video camera I could show you what I mean.

Edit: this issue was meant to be posted in n2 thread a few days back. It was fixed by removing noise reduction on the n2 via ssh command (see n2 thread).

Hi, do you still have plans to add full rgb mode?
I’m lookin for *elec device with full rgb range but now, especially from matrix builds, elecs on all platforms output ycbcr limited, can’t find a way to change it.

  1. amlogic - always was ycbcr limited
  2. rockchip - it was full rgb, prior to matrix builds, but now - ycbcr limited
  3. rpi4 - Le20 - limited (full range config parameter ignored)
  4. just on elec for pc - range is full.