.iso support?


#1

Hi,

as the title suggests, is coreelec supposed to support .iso files?

i have numerous DVD iso files both movies and DVD audio but they don’t show. if i navigate to my share both from video files view and music files view the directories appear empty. if i navigate in file manager i can see the ISO files. if boot to droid, SPMC can see and play them.

i tried installing the SACD iso support addon (i also have some SACD iso recently downloaded) but it made no difference…

is his supposed to work, or a know problem, or something screwy with my system?

Thanks!


#2

That is not a question specific to CoreELEC but to Kodi in general. DVD-V.iso works out of the box, DVD-A is not supported at this time. SACD.iso is work in progress and only works for the stereo layer of SACDs at the moment. There are specific support threads for all of the above at the KODI forum.


#3

Thanks,

my problem is in file view in video kodi on corelec, it does not recognize the .iso extension, DVD-V.iso does not work out of the box for me on corelec kodi. The folder that contains the ISO appears empty. in SPMC i see the .iso file and certainly the video ones play (i have around 50 .iso files that are all guitar lessons that i use, but not since switching to corelec, i have to boot back to kodi in droid to play them, and they are working OK in SPMC and Krypton on droid - not tried Leia on droid)


#4

SPMC is a fork of Kodi with many different patches that add additional functionality… voice search on Android for 1.

CoreELEC uses pure-Kodi and not SPMC.


#5

‘Dvd-v’ works just fine for me, i use it quite often.
Is there something special about your .iso files?

If they follow standards there should be no issue i think.


#6

Please record a debug log showing you trying to play an iso, then post it to a pastebin and copy the link here.


#7

Out of curiosity

you don’t happen to have something like

<videoextensions>
    <remove>.bin|.img|.iso|.zip</remove>
  </videoextensions>

in your advancedsettings.xml file?


#8

thanks for the replies,

i don’t have those settings in my advanced settings.

unfortunately i cannot post a debug log showing playback of iso failing, i simply don’t see the .iso inside its folder. it appears like the folder is empty. the only time i see the iso file in the directory is when using file manager, but that does not give me option to play…only if i load kodi in droid do i see the iso files in their respective directories in video files view, and i am able to play…


#9

Figured it was worth asking, since that would give the exact symptoms as the problem you are describing.

I didn’t see mention of which version of CoreELEC you are using?

Can you try a fresh install of 8.95.6, don’t install any repos/addons, or change anything, just go straight to seeing if it shows the .iso for you.


#10

I can confirm that CoreELEC has always been a little picky with DVD .ISO images.
Most play fine and others do not. I can’t offer an explanation as to why (can only presume there is more than one ‘type’ of DVD image) :thinking:

I’m always able to see every image though, so not sure if it’s related to your issue or not.

Update:
The latest build plays all of my DVD .ISO images fine :grin:


#11

Kodi does support ISO files, although they need to be unencrypted and with the appropiate file structure inside (VIDEO_TS, AUDIO_TS folders)

https://kodi.wiki/view/Features_and_supported_formats#Format_support

  • Physical digital media: Blu-ray Disc (unencrypted), CDs, DVDs, DVD-Video, Video CDs (including VCD/SVCD/XVCD), Audio-CD (CDDA), USB Flash Drives, and local Hard Disk Drives

#12

Thanks all, i am on 8.95.6.(upgraded this weekend) and issue persists.

@ cuda13a - will try a fresh install with no addons / repo’s etc and update.

@ Poida - yes i was expecting to see the .iso even if it does not play, i have had some .iso files in the past that would not play, but i was always able to see them - I would get error along the lines of ‘too many playback items failed’ or similar - i didn’t keep those images…


#13

Somewhat related, but I’ve noticed since Kodi 18 beta with my Amlogic S912 box (it’s a T95Z Plus) that video DVD ISO playback (the ISOs are not encrypted) is always laggy and jerky. It happens in every CoreELEC build I’ve tried (using the latest 8.95.6 right now) and it doesn’t matter if the ISO is located on a USB hard drive, SD card, etc. I’ve tried changing multiple settings and whatnot, nothing helps.

However the strange thing is, when I boot into the eMMC Android partition with Kodi 17.6 installed, they playback fine… but if I update to Kodi 18 beta or even RC, the laggy ISO playback happens there too.

Fortunately my workaround was to rip all the ISOs to MKV and those play fine too. However, I’d like to eventually restore video DVD ISO playback.

Is it a known Kodi 18 issue? Or is it a issue with my S912 box? Or something new or something else?