Issue playback 4K mp4 file

I’ve installed CoreElec latest nightbuild and Kodi 18 RC4.All my 4K mkv files are displayed as 4k on my 4k tv (Q9FN) and player is S912 one connected via receiver A820, for example 3840/2160 24p or 30p is sent directly without transcoding. Followed the default kodi settings 1080p for gui etc

Now i’m running into an issue. MOV files are not played perfectly so I choose to have mp4 output from my 4K cam. Playing this mp4 file, the receiver mentioned 1920/1080 at 50p, The receiver is set to direct the video towards tv without processing.

Complete name : \diskstation\4k\dji\DJI_0317.MP4
Format : MPEG-4
Format profile : JVT
Codec ID : avc1 (avc1/isom)
File size : 240 MiB
Duration : 33 s 640 ms
Overall bit rate mode : Variable
Overall bit rate : 59.9 Mb/s
Encoded date : UTC 2019-01-18 14:08:51
Tagged date : UTC 2019-01-18 14:08:51

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings : CABAC / 1 Ref Frames
Format settings, CABAC : Yes
Format settings, RefFrames : 1 frame
Format settings, GOP : M=1, N=12
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 33 s 640 ms
Bit rate mode : Variable
Bit rate : 60.0 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.289
Stream size : 240 MiB (100%)
Title : DJI.AVC
Language : English
Encoded date : UTC 2019-01-18 14:08:51
Tagged date : UTC 2019-01-18 14:08:51
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

What do I have to do, like settings, to let the receiver say it’s an 4K file and no downscaling has to be performed within Kodi, cause that is what i think is happening, or is the message on the tv saying its receiving 1080p input just something to ignore?

is this something to look into?

Can’t help without a log.

W’ll try to produce a log.

Remove file on request due to gave too much info.

Hope this is the log you requested.

@mtv I have the same TV, similar Yamaha receiver and K1 plus combo (S905). I have no problem playing 4k videos and TV shows the correct resolution 3840 x 2160 and fps. I would check the whitelist and set it as is recommended as I see this in your log file:

Whitelist is empty using default one
19:47:44.005 T:4092212304 DEBUG: Trying to find exact refresh rate
19:47:44.005 T:4092212304 DEBUG: No exact whitelisted resolution matched, trying double refresh rate
19:47:44.006 T:4092212304 DEBUG: No double refresh rate whitelisted resolution matched, trying current resolution
19:47:44.007 T:4092212304 DEBUG: Matched fuzzy whitelisted Resolution 1920x1080 @ 50.00 - Full Screen (29)

Also not sure about the others but I found quite painful to read your logfile because you left scraper running with all downloaded movies at the background and it really interfered with the information you need us to read.

Also I would recommend to connect media box directly to TV because Samsung’s CEC implementation is piece of crap and I had many outages if connected through AV receiver. So if you will come to problems like not-working CEC, ghost off/on etc… just reconnect your HDMI cables.

This was first attempt , i’m not that experieced with log files :wink: so didn’t know what he was sending.

Will dive into it.

Just to be clear. Only this type of mp4 or convertend to mkv from my 4k cam files i’ve sent info about in the first message are making trouble.

The rest of mkv, m2ts and tv series in mkv don’t have those issues.

But now i’m thinking about what you mentioned about refresh rate, i guess my receiver is blocking here, will try your suggestion about connecting to tv directly. I guess sound will still be sent to receiver?

The reciever has mon.chk activated, but turning that off (skip) didn’t change anything. Will try moving device to tv as next option.

Last test resulted in this:

MP4 file 4096 * 2160 24fps works and displayed correct on tv via a820
MP4 file 4096 * 2160 25fps displayed on tv via a820 as 19201080 50P
MP4 file 3840 * 2160 24fps works and displayed correct on tv via a820
MP4 file 3840 * 2160 25fps displayed on tv via a820 as 1920
1080 50P

Will stick to 24 fps mp4 on 4k cam. Must be my tv that won’t like 25fps. No problem. Resolved. Sorry for to send too much info in log file.

1 Like

Glad you solved that. About the question about sound and connectivity. I have AV receiver connected to ARC HDMI port while media box to some another. And just because if I have media box connected to AV receiver the QE65Q9FN would not correctly utilize CEC between media box and the TV. Mostly no commands went through. Samsung’s tizen is such a crap. But if I connected the media box directly, another story. Everything running smootly. I can control media box using TV’s remote. Audio goes nicely to AVR if ON. Volume controls on media box also controls AVR’s volume, same as TV’s control. I’m just not sure how would audio passthrough works, I do not use it, I have stereo speakers anyway.

Yes glad it’s solved in that way, so 4k cam can be used again.

With me just another situation, media connected to avr and tv to hmdi arc out. With cec connector on mediabox from CE everything is going on when power on mediabox. Volume is working great with tf remote, receiver recognize this. Even mediabox is reacting on tv remote.

Was earlier a big problem, hdmi cec from tv to receiver wasn’t working anymore, had to powerdown many times to get connection between tv and receiver, even arc didn’t work anymore, so no netflix sound to receiver. Due to mediabox cec this works perfect again, even arc is now working

Do agree with you that hdmi is difficult between those devices, had it other way around for many days.

F@ftelf just tested my h96pro+ s912 device added to my 2018 Q9FN tv on hdmi3. Same result with 25fps file, recognized as 1080P

(Had hmdi4 arc still active, but selected hdmi3 on tv)

Also used a 4K sample file from, a 300mb hevc file. Played perfect as 1920/1080p 50 file

A guy on used this on his vero 4k device.

So tv must be the issue here.

Have you tried connecting the box directly to the TV?
Maybe the receiver doesn’t “like” a 4K@50Hz signal.

Yes i attached the device directly to the tv on hdmi3 and selected source on tv. Tried also with remove hdmi4 (arc).

i didn’t do anything with the whitelist on kodi.

even tried with (HDR HEVC 10-bit 25fps) Astra DVB Sample.ts from

even tried jellyfish-140-mbps-4k-uhd-hevc-10bit from

same effect 1920/1080p 50p

Changed device to vero 4k+ and now the earlier mentioned files plays perfect on tv, 4k output on tv, instead on 1920/1080p. Direct on tv and also via receiver (direct)

Did sev files, all ok. Must be setting within kodi on h96pro+.

That will do for me. Will keep the vero :grinning:

So solved for vero, sorry.

Thanks for helping @Ftelf and @TheCoolest !!!