Issue with X2 Air Cube after update to Matrix

I have a Ugoos X2 Air Cube that is running their rom which is dual boot android and coreelec. I know this wasn’t the recommended method when I did it, but it has worked for a year, I never even know Android is there as it boots to Coreelec. I made the mistake of updating to Matrix through the coreelec UI.

All went well, it seemed to hang on “migrating addons” so I pulled the plug. (did this yesterday with a C4 and had no issues) now it boots to the coreelec splash screen and just hangs there, tried a couple reboots, nothing. Sat for over an hour.

I have two questions:

  1. Is there anything I can do to fix this?
  2. If not what is the best way to install coreelec on this device? I don’t care about Android, seems like I will need to install the original android rom and then use the coreelec emmc tool, is that the best approach?
    Or should this work?
    How to install CoreELEC
  1. Clean fresh install as upgrade from 9.2 to CE-19 is not recommended.
  2. ceemmc, but your device isn’t official supported. So it’s on your own risk.

Curious about this. What would be the recommended way then without the tool?

If you can still SSH in you can rename the .kodi folder & reboot. That’s what I did. Once it’s created a new Kodi folder & working you can remove the old Kodi folder.

Was able to boot with a new install on an SD card, it works for now, although of course everything is wiped but wasn’t expecting to recover. With this method I have to hole reset at every reboot, so not permanent but happy the box is working.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice