Issues with seeking my x265 encodes

Hi, I just recently switched from Libreelec to Coreelec and am having trouble seeking since making the switch

I encoded my family movies in x265 and cloned the settings of one of the largest release groups I could find Megusta. The videos play fine but seeking in any direction causes the video to freeze for ~30 seconds, sometimes indefinitely.

All other formats I’ve tested work great, so the issue lies with the encoding settings I’ve used. But I’m already pretty far down the rabbit hole as I’ve been encoding like this for years because it worked flawlessly on Libreelec. Are there any tips or hacks I can do so I can regain the seeking behavior I had previously?

I know i grasping at straws here as Core was a major rework under the hood.

Thanks,

Is that better kostaman, or have I already said spite?
-https://www.youtube.com/watch?v=fP0MXJAQhmo

a} Try Enabled HEVC seek workaround in Options/ Settings/System/CoreELEC
b} Try remuxing them with mkvtoolnix

Hi ffimon,

Enabled HEVC seek workaround didn’t have any effect, same behavior.

I just ran a video through mkvtoolnix without changing any settings and unfortunately no change to the seeking issue.

When i scan the logs i get the following on repeat:

2019-11-23 22:53:58.101 T:3406558080 ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer 2019-11-23 22:53:58.139 T:4067967872 WARNING: ActiveAE - large audio sync error: 591405.900915 2019-11-23 22:53:58.145 T:3517666176 DEBUG: CAMLCodec::GetPicture: VC_BUFFER LEV:0.00 ttd:-9223372036869054ms x:100.000 <null> 2019-11-23 22:53:58.200 T:3517666176 DEBUG: CAMLCodec::GetPicture: VC_BUFFER LEV:0.00 ttd:-9223372036869112ms x:100.000 <null> 2019-11-23 22:53:58.225 T:4067967872 WARNING: ActiveAE - large audio sync error: 591320.683333

I guesses i can explore?

Its something to do with the audio syncing.

when i remove the audio entirely in Mkvtoolnix the seeking issue goes away, i can FF and RW with zero issues.

Are you playing the files locally or streamed over from a server/NAS etc?

For the sake of troubleshooting I’m only testing locally.

/storage/video/

OK

I did find this thread with a similar issue but it turned out to be network related.

I hear you, there are a number of failure points going from a NAS. but no, same behavior when running right from the SD card. But I did make a small discovery:

seeksteps, or rather seekdelay is having an effect. I increase seekdelay to 2.5 seconds and now seeking is successful ~60% of the time?

I was under the assumption seekdelay was nothing more than a delay on your seek input before actually pushing through the command. how could that result in audio sync issues being alleviated?

This is bizarre. with seekdelay set to 2 seconds its working reliably for the most part. bring it down to zero (aka old kodi seeking behaviour) and the issue is reproducible every time.

I guess problem solved.

thanks for the help

I have some encodes of the same type but my system always recodes the audio only down to AAC-HE V2 as nearly all my content is played back though a tv and not a 5.1 Surround system.
I have one thing you can try to narrow this down that may or may not have an effect.

Recode the audio only first is 6 Channel second is Stereo

ffmpeg -i Input.mkv -c:v copy -c:a aac -q:a 2  -a:c 6  -strict -2 Output6ch.mkv

ffmpeg -i Input.mkv -c:v copy -c:a aac -q:a 2  -a:c 2 -strict -2 -af "pan=stereo|FL < FL + 1.414FC + .5BL + .5SL|FR < FR + 1.414FC + .5BR + .5SR, volume=1.5"  OutputStereo.mkv

It will take about 5 mins to do

I appreciate the help ffimon, it turned out to be the GPU overclock option.

Not sure why i didn’t think of that right out of the gate.

Just to help others exactly what exactly did you change to fix it.

I had it enabled, to turn it off you need to be in “expert mode” and the setting is found here:

Settings > System > CoreELEC > Enable GPU overclock

I tried the video in your 1st post above but I had no issues with it?
Is it in H265?

@apeg are you saying having the GPU overclock turned on; caused your issues?

I was never a fan of this option and didn’t see the point of it when it was first added.

@bazzle, The Seinfeld video was just a take on the ironic situation I’d got myself into and had nothing to do with my technical problem.

@adamg, you got it, on all my c2s. when GPU overclock was enabled seeking on x265 content I encoded would have issues. Night and day fix, turn it off and seeking is better than I remember it on Libreelec.

@apeg thanks, I will make sure this is removed from our next release.