Json RPC Server not start automatically

Latest build. commit 0a2db60ae4cd9ed9e85d2aca70ce8c23bbbe8654 Json RPC server does not start automatically.
netstat -an | grep 9090 nothing shows. After turning off and on the rpc settings
netstat -an | grep 9090 showing tcp 0 0* LISTEN

kodi-ce-107-silence-race-condition-error.patch This patch breaks Json RPC Service

I was already aware of an issue with the JSON RPC server, the problem is that Kodi starts too quick before the network is fully up.

You can solve this by going to Add-ons > CoreELEC Configuration > Network and enable Wait for network before starting Kodi.

It’s not working. The removal of the patch and the new build helped. I see you have already fixed in f43b38ed89edbce24b60a1781e91d628615ae13a. Thanks.

I’m still suffering this bug in 9.0.3.

When CoreElec starts, half of the times I get a “JSON RPC could not start” message. Restarting KODI (not corelec) solves the issue. But I have some addons which depend on having JSON RPC enabled and it is very frustrating having to restart Kodi every time.

I have “Wait for network before starting Kodi” enabled, and it does not help. I’ve seen there is a similar systemd unit that I’m not sure if it’s enabled or not.

systemctl is-enabled whatever.service

0 if it is enabled, 1 otherwise.

It works now that I increased the wait time from 5s to 15s. Not sure why, though, since 5s should have been enough, but it works now (with 9.2.0 at least).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.