Khadas Vim Pro won't work with installtointernal

Hi,

I’m using Khadas Vim and also other SBCs including s912 and RPIs.

I’ve been using adamg’s great distro about 6 months or so. and found out older version is no longer available and it’s been changed/merged into CE.

So, I’ve tried to install and enjoy it. but have some problems.

  1. installtointernal command won’t work on 8.90.2 distro for KVIM (not for KVIM2). It shows there’s some problem with dtb.img or something. (I’m using VIM pro)
  2. A bit slower than the older version of LibreElec 8.90.x. especially IR reaction. but, it might be just my problem.
  3. Trying to use Netflix on KVIM, but it keeps crashing during installing Wildvine to KVIM. I guess it might be a problem with 4GB SD card, but not sure. if you have any suggestion on that, I would be really happy :slight_smile:

Thank you.
Daniel.

installtointernal isn’t recommended (or officially supported) :neutral_face:

  1. you need to have at least 2 gb space for widevine download and extraction.
    YOu could try to install sandmans amazon plugin which comes with inputstream helper. This takes care to install widevine

Thank you for your reply, but I’ve already been using the Khadas VIM with installtointernal on LibreELEC 8.2.2.3 and worked perfectly.

Also, you can always go back to any OS(Several version of Android and Linux) without any problem, cause the manufacturer is providing proper OS image from their website. so, I didn’t hesitate a second.

The other reason I want to use installtointernal is eMMC on the board is way faster/bigger than SD card.

Thank you for the information.

But, first the SD card was available more than 2.1GB , but size shouldn’t be matter. and as I tried it again I’ve erased some of the remains on the storage and tried.

But, I’ll try to do your suggestion. actually, I’m checking bad sectors of SD cards, which might cause problems on storage.

It usually does work and therefore has been left accessible (after being disabled a while back), but since it can, and has, caused trouble for some it’s not recommended (or officially supported) :wink:

It seems the SD card has a problem, I’ve changed it to another one and worked. Thank you. tavoc :slight_smile:

I figured out what went wrong. ever since 8.90.1 distro’s installtointernal command for KVIM was changed intentionally. So, I’ve installed 8.90.0 and installed to eMMC and upgraded it to 8.90.2

It seems work okay. but Neflix subtitle is another issue. I’m trying to solve it but, not sure.

1 Like

Good to hear you got it sorted out :+1:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice