Khadas VIM3 testbuilds

For android/CE switch, only need plugging in and out the usb stick.
Personally, not suggest to install in emmc especially for new CE user.

The top cover is mounted in reverse. :slight_smile:

1 Like

Kind reminding! :hugs:
Careless mounting for the last time, as never use the 40-pin.

after suspended, push vim3’s power botton can’t resume . but with remote’s power key, it can, is it normal?

The VIM3 specs say the CPU should go up to 2.2Ghz but CoreELEC seems to be limited to 1.8Ghz.

cat /sys/devices/system/cpu/cpufreq/policy0/cpuinfo_max_freq
returns 1800000

How do we get the full 2.2Ghz? I’ve tried setting:-


in config.ini but I still only get 1.8Ghz

Did you try the bl301 injection? CoreELEC BL301 Wake-Up feature [inject_bl301]

Update first with the newest tar and run the command after reboot.
After injection reboot and test if the power on button is working now.

Don’t be afraid to break something, the next time you upgrade with a tar the bl301 injection is gone :wink:

@TheCoolest has fixed this today and uncapped the VIM3 from 1.8Ghz to 2.2Ghz, you should notice a visible improvement with tomorrows nightly.

I updated to the lastest nightbuild 0819, and run inject_bl301,it says:
Starting bootloader blob BL301 injection tool v0.1…

This tool can be used to update the bootloader
blob BL301 of the vendor bootloader on the internal
eMMC. This bootloader blob BL301 is customized by
Team CoreELEC to support all wake-up features like
CEC, Wake-On-LAN, IR, and GPIO wake-up from
suspend or power off state!

Device serial number:
Using CPU type G12B (29): S922X, A311D
Using binary type because of CoreELEC DT-ID: Khadas_VIM3
Using /dev/bootloader as bootloader partition
Found TOC_HEADER at: 0x00010210
Name: AA640001
Serial Number: 12345678
Flags: 0

Offset Address: 0x5C000 (absolute: 0x6C210)
Size: 0xE570
Flags: 0x0
Found BL30 blob image at: 0x0006C210
Amlogic magic: @AML
Old signature: 292DDFEFF19F4B380622CEDE0F3ED6997D90650CBC1E8691BBDFA6C836B31DEE
Using BL301.bin: Khadas_VIM3_29_bl301.bin
New signature: 292DDFEFF19F4B380622CEDE0F3ED6997D90650CBC1E8691BBDFA6C836B31DEE
Update of BL301.bin on eMMC is not needed, exit now…

after reboot,
power on botton can suspend vim3, but still can’t resume.

PS: power botton can power on vim3 from shutdown.

I think there is another issue with suspend resume & HDMI.
Another S905X2 user say the same, power off resume is working, suspend resume -> black screen.
So I guess it wake up as the wake up function is same for power off & suspend but you don’t see anything on the TV. On a power off and resume the HDMI interface get initialized again so this is the reason why you see the resume on TV.

I will see if I can reproduce with my TV.
What TV, brand, type you have?

EDIT: I just checked it with the power button:
One press, kvim3 power off, second press wake-up

Sending the kvim3 to suspend, wake-up with IR is working, power button not.

This is the problem I encountered

The problem (resume by power button on suspend) should be solved tomorrow in the next nightly - there was a bug in bl301 binary.

Thank you, I’ll test it tomorrow.

I’ve been using my vim3 for a couple of days now and so far imo at the moment it’s a downgrade from my s912 :frowning: CEC is very intermittent sometimes it works and sometimes I have to power the tv on and off to get it to work which doesn’t always work and other times I have to use my Bluetooth remote to go into cec settings and restore to default which gets it working temporarily but as soon as I change input on my tv and then go back to kodi CEC stops working again. It’s also not saving my audio settings it keeps resorting back to PCM so I get jsut static noise through my avr
I didn’t have these issues on my s912, CEC worked flawlessly I could switch my tv between inputs and on and off and it always worked straight away so I know it’s not a issue with my tv (Panasonic). Audio output settings also never changed on the s912.

I’m hoping these issues were caused by me restoring from a backup from my s912 and using the generic build because the vim3 build wouldn’t boot so my question is to restore with a fresh installation what build should I use? (VIM 3 Pro 4gb ram)

Another strange behaviour I’ve just found is when I turn my tv off a few minutes later it turns back on on it’s own with CE as the input and the only way to keep the tv turned off is to unplug the VIM3 power supply. It doesn’t make any difference what the last input I was watching was ie VIM3 is on hdmi port 1 but if I turn the tv off while watching built in freeveiw it still turns back on after a few minutes and automatically changes input to CE
Again this behaviour was not present in my s912

VIM3 has just started the development cycle so you can’t really compare it with a SOC that’s been around for ages. I can assure that you’ve not downgraded anything. You have one of the best amlogic SBC’s available in the market.
Please keep reporting any bugs you find and the Team will address those.
Have a little faith in the Devs!


Comparisons are not necessary :slight_smile:

Turn off CEC as an interim workaround either on your TV or on CE, your VIM3 will stay powered on but at least you can turn your TV off.

Please post a log: How to post debug logs

And please do not use your backup from the S912!
Make a fresh install will solve a lot of issues already :stuck_out_tongue_winking_eye:

I did wonder if by restoring from a older backup I could have caused the problems myself… what build should I use to do a fresh install, should I still go with the generic one?. I will do a fresh install then post debug log

There is no special img.gz for kvim3, please use last available generic-ng nightly.

Thanks, I’ve just created a sd card with the latest generic Ng nightly and renamed dtb but it keeps booting my already installed CE, I have it installed to internal. What am I doing wrong, do I need to do something to make it boot from sd?
Thanks again for your help!