Khadas VIM3 testbuilds

Yes I have the Heatsink and the thermal pad between the bottom of the pcb and the metal base of the case, my idle temps are normally around 40•, out of interest I left the fan on level 3 for a few minutes and the temp dropped to 28• .

Thanks for adding fan functionality to the Vim3, it makes a big difference :slight_smile:

Unfortunately after upgrading from 9.2.1 to the latest nightly I now have a weird cyan/blue coloured screen instead of the red/black scheme. Is this a known issue?

You can check the following post:

Thanks Vascobraga. That worked perfectly well.

Just arrived today - vim3l with CE preinstalled. As mentioned in other posts - all sort of video playback is in forced-HDR mode, even GUI is in HRD and there is no digital sound available.

I am trying to install latest nightly build and its seems to be stuck in here

How long does it take to install the latest nightly mode from external usb drive and is this normal behavior of the installation?

I have followed the process to install from external media as it is described.

You only have to copy and paste the latest Nightly .tar into the .Update folder.
You already have a CE OS installed to eMMC

Also read this How to fix green screen issue with VIM3?

This is not normal, I don’t know what you have done.

The HDR issue can be resolved by running the following command from SSH.

fw_setenv sdr2hdr 0

Adamg, this is out of the box, just arrived to me. Powered with Amazon`s Echo Dot power brick, plug in with certified HDMI to the AVR and tried to run some tests and movies:
Remote controller - working fine. Even the smart remote of my Q9FN is working
1080p - not able to play - movie starts, but then playback stuck, then resume again and so forth…
4k - not able to play - same situation as 1080p
All content seems to be in forced HDR - will try to fix with the command you gave me
HD sound - not able to play
DD and DTS sound - working fine
Sound when in GUI - working fine
Its like the sound passthrough is forced to go to the SPDIF instead to HDMI
Then, what about TruHD and MA passthrough - is there another command?

Isn’t Alexa a virtual assistant ??
Never heard of a product named Alexa Power Brick.

True - powered with Amazons Echo Dot Gen1 power brick :slight_smile: but thats not the point

All issues were fixed after updating to Nightly_20191222:

  • No inverted colours after the update
  • No forced HDR
  • Original remote does not work, but my Samsung Q9FN smart remote is working fine
  • 1080p smooth play
  • 4k HDR and HDR10+ smooth play - tested with movies and some demo videos
  • HD audio passthrough is working fine

Needed to turn on “Disable GUI scaling” otherwise the display was zooming when in 4k and cropping when in 1080p.

to fix zooming, cropping correct way below:

Next Nightly will sort out amremote as long as you copy and paste remote.conf into .config folder.

Hello, are there any improvements compared to the stable build 9.2.1?

@TheCoolest VIM3 with the (new)nightbuilds, VFD doesn’t work

[    6.307000@4] OpenVFD: Version: V1.3.0
[    6.307006@4] OpenVFD: vfd_gpio_clk:         #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307008@4] OpenVFD: vfd_gpio_dat:         #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307009@4] OpenVFD: vfd_gpio_stb:         #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307011@4] OpenVFD: vfd_gpio0:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307012@4] OpenVFD: vfd_gpio1:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307014@4] OpenVFD: vfd_gpio2:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307015@4] OpenVFD: vfd_gpio3:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;                                                     
[    6.307016@4] OpenVFD: vfd_gpio_protocol:    #0 = 0x01; #1 = 0x03;
[    6.307018@4] OpenVFD: vfd_chars:            #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04;
[    6.307021@4] OpenVFD: vfd_dot_bits:         #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04; #5 = 0x05; #6 = 0x06;
[    6.307022@4] OpenVFD: vfd_display_type:     #0 = 0x1F; #1 = 0x3C; #2 = 0x00; #3 = 0xFD;
[    6.307025@4] OpenVFD: Detected gpio chips:  periphs-banks, aobus-banks.
[    6.307026@4] OpenVFD: Skipping vfd_gpio_clk evaluation (0xFF)
[    6.307027@4] OpenVFD: Skipping vfd_gpio_dat evaluation (0xFF)
[    6.307027@4] OpenVFD: Skipping vfd_gpio_stb evaluation (0xFF)
[    6.307028@4] OpenVFD: Skipping vfd_gpio0 evaluation (0xFF)
[    6.307028@4] OpenVFD: Skipping vfd_gpio1 evaluation (0xFF)
[    6.307029@4] OpenVFD: Skipping vfd_gpio2 evaluation (0xFF)
[    6.307030@4] OpenVFD: Skipping vfd_gpio3 evaluation (0xFF)
[    6.307217@5] OpenVFD: Select SSD1306 controller
[    6.307221@5] OpenVFD: HW I2C interface failed to intialize. Could not get I2C-3 adapter
[    6.307223@5] OpenVFD: Failed to initialize the controller, reverting to Dummy controller

back to 9.2.1, works fine.

Reboot and post a full dmesg log.

Please try this DTB and let me know if it works.

Tried, but no luck…I stopped kodi, I deleted the whole /resolutions/ section in the guisettings.xml and when I switched to 2160p, I got the no-signal screen (like there is nobody at the HDMI port) but after 5/10 seconds it got back to 1080p.
Secondly, when I try to play 4k I am getting, again, the no-signal screen and then I have to stop/start kodi (or reboot) in order to get back the image on screen.
Do I have to switch back the “Disable GUI scaling” option?
I am now running on Nightly 20191223, this was not observed when I was on the previous build.

It’s probably a bad HDMI cable that can’t handle the bandwidth of 4K.


Thanks, Replaced with this dtb file, it works.