Khadas VIM3L IR and CE 19.X

Hello all!

I have a question that may have been answered but to the best of my knowledge a solution has yet to be discovered.

I’m currently remaining on CoreELEC 9.2.7 for one reason: out-of-the-box IR remote functionality. No IR is a deal-breaker.

My machine is a Khadas VIM3L and the remote control is an Xbox 360 Universal Media remote (programmed into another remote that can “learn” keypress codes). The IR works fine on any CE build prior to 19.X.

Are there steps I can take to enable IR controls on the unit using CE 19? I’m familiar with using SSH if that’s required to add or delete files.

Thanks for the help!


I tried all steps uploading files via SSH and still can’t get the remote to function.

When reaching the step using the ir-keytable commmand I get this error:

ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
/sys/class/rc/: No such file or directory
No devices found

I have created the remote.force_meson_ir file and the rc_maps.cfg in the .config folder as well as the L336.toml file in rc_keymaps downloaded from the repository.

Is there still a step I am missing?

You did stop kodi? You stopped eventlircd?
Your remote is working? You can check it with the camera on the phone if the LED light up on keypress.

Yes I stopped both processes and I know the remote is working because it received all commands before upgrading CE 9.2.7 to 19.2 RC 2 on the same device.

Could having used a Khadas Krescue image have anything to do with the problem?

Kresuce images are not supported by CE.

Try the steps listed here.

I’ve scoured and attempted to do a clean install an official CE 19 release onto the eMMC of the VIM3L but to no avail.

Is there a microSD flashable utility to install official CE builds onto the internal eMMC that isn’t Krescue?

I followed all steps listed in the guide but still get the “No devices found” error on anything involving ir-keytable. :frowning_face:

Can you please provide a log? Thank you.

Sure thing! The log address is

Right now I do not see any error in the log, only that you still use a krescue image.
We have no idea what could be the reason as it works every where else.
So for further support you will need to reset your device!

Download Khadas Android Firmware (max 210128, newer one are not compatible anymore with ethernet and LAN will not work) and burn it to the device with USB tool.
Then create a new CE bootmedia on uSD or USB and try again.

Oh right, I need to get off of the Krescue images! :grimacing:

Is there a CoreELEC installer that can run on a microSD so the official supported builds can be installed directly to the internal eMMC instead of side loading from Android OS?


CoreELEC isn’t sideloaded from Android OS. And please use the search feature in the forum. And please do as Portisch said. And please accept the help. You’re not helping yourself. And it’s frustrating trying to help those who don’t want help. If this is not good enough for you, please go request help at khadas forum. That’s the right place if you’re using Krescue.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.