KII Pro (Videostrong S905) No Wifi

#1

I have KII Pro old Videostrong based on S905.
Generally, I’m using Lan connection but I recognize that Wifi is not working at all.
No networks search on CoreElec settings. I also run Stock Android and there’s I also can’t run Wifi. Does anyone have a similar problem?

When I run command:
dmesg | grep wifi

It return:
[ 0.277008@0] wifi: power_on_pin_OD = 0;
[ 0.277021@0] aml_wifi wifi.30: [wifi_dev_probe] no power_on_pin2
[ 0.277054@0] aml_wifi wifi.30: [pwm_single_channel_conf_dt] pwm phandle val=34,pwm-channel=4
[ 0.277065@0] aml_wifi wifi.30: [pwm_single_channel_conf_dt] pwm_config[0] = 30519,pwm_config[1] = 15260
[ 0.277075@0] aml_wifi wifi.30: [pwm_single_channel_conf_dt] wifi pwm dt ok
[ 0.277092@0] aml_wifi wifi.30: [pwm_single_channel_conf] wifi pwm conf ok
[ 0.277135@0] aml_wifi wifi.30: [wifi_dev_probe] dhd_static_buf setup
[ 0.277209@0] aml_wifi wifi.30: [wifi_dev_probe] interrupt_pin=235
[ 0.277217@0] aml_wifi wifi.30: [wifi_dev_probe] irq_num=100, irq_trigger_type=1
[ 0.277227@0] aml_wifi wifi.30: [wifi_dev_probe] power_on_pin=234
[ 0.277236@0] aml_wifi wifi.30: [wifi_dev_probe] clock_32k_pin=0
[ 0.277406@0] aml_wifi wifi.30: [wifi_setup_dt] wifi_setup_dt
[ 0.277435@0] aml_wifi wifi.30: [wifi_setup_dt] interrupt_pin(235)
[ 0.277450@0] aml_wifi wifi.30: [wifi_setup_dt] power_on_pin(234)
[ 2.725934@0] efusekeyname: mac_wifi offset: 12 size: 6
[ 18.440560@3] aml_wifi wifi.30: [extern_wifi_set_enable] WIFI Disable! 234
[ 18.741185@3] aml_wifi wifi.30: [extern_wifi_set_enable] WIFI Enable! 234

Full output of:
dmesg

https://pastebin.com/KLfBrQvD

#2

Hi,

There are two versions of KII Pro. The oldest with S905 SoC uses gxbb_p200_k2_pro.dts dtb. For the newest with s905D SoC, there is not a specific dtb, but I have used gxl_p231_2g_dvb.dts for a while and everything works well with it.

I think that you have the KII Pro new version and you use the old dtb. Isn’t it?

#3

I have an older one (S905 with Android 5.1.1) and used gxbb_p200_k2_pro DTB file.
Strange is that also on Android I can’t turn on WiFi. Maybe it’s a hardware problem…

#4

I have Mecool M8S Pro, the wifi on andoid packed up on mine, I was lucky & got a refund, & still kept the box. Running coreelec, the wifi still doesn’t work.

I suspect a hardware problem.

#5

Maybe problem is that WiFi module in my KII Pro is different that other models described in Internet.
Generally everywhere I can found specification and photos insides of this Box WiFi module is described as:
km63351412 (replacemnet of AP6335)

On mine Board I can see module with symbol:
KM3306005

I didn’t find on the internet any useful information if this is another replacement of AP6335 or totally different module needs other drivers

#6

If it’s not working in stock Android, as well as CE ,
Most likely Hardware Failure .

1 Like
#7

I agree with You but in Russian forum I can see information that after some Firmware Update of this Box for some people WiFi stopped working and they also delivered files which copied to Android FS fix this problem:

https://4pda.ru/forum/index.php?showtopic=763495&st=4200#entry61777519

Links to files already not working so I can’t confirm on Stock Android.

#8

Your Box has a CE Supported Wifi Chip.
Realtek RTL8189

10/100 Lan

My opinion is you buy a USB Ethernet adapter. That’s what i would do.

#9

This is strange but here different information included:

802.11 b/g/n/ac Wi-Fi, and Bluetooth 4.0 (Ampak AP6335) – Not Realtek RTL8189 as shown in Aliexpress according to VideoStrong.

#10

Another information from here: https://forum.xda-developers.com/android-stick--console-computers/amlogic/android-tv-kii-pro-dvb-s2-t2-t3690529/page14

VS uses 2 revisions of Broadcom chip with same ID (BCM4335). Difference is in revision. 1st is bcm4339a0 (used in Ampak modules) and 2nd is bcm4335b0 (module without metal shielding that can be seen on Ampak modules)

Mine is without metal shielding means Ampak AP6335:

#11

Can you ssh and run.

udevadm info /sys/bus/sdio/devices/sdio*

#12
CoreELECKII:~ # udevadm info /sys/bus/sdio/devices/sdio*
Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.

Nothing inside devices:

CoreELECKII:/sys/bus/sdio/devices # ls
CoreELECKII:/sys/bus/sdio/devices #
#13

Is the Chip: bcm4339 supported by CoreELEC? If yes then it can really be hardware problem and I’ll try to resolder it.