KIII Pro DVB-T2 / DVB-S2 help please

Hi,
I just got my new K3 pro, whi I would like to try as a replacement for old enigma box. I have 2 sat dishes - 1x 19.2 / 23.5 and 1x 28.2, joint into one cable and then into K3 pro. Also have 2nd cable with dvb-t2 signal connected into K3 pro.
I installed latest Coreelec, but there is no dvbt/dvbs settings. Can anyone point me to a right direction with step by step guide please? Thank you

I don’t have the possibility to reset my box to factory defaults to see what exactly needs to be done, in order to write a guide. But something along these lines should work.

You first choose a DVB driver via Addons -> LE Module Drivers. Unfortunately I can’t remember if KIII driver is included in the default driver package even though I have the same box but since I use an external USB based tuner mainly so I have chosen the CrazyCat package.

Then you need a backend software, some popular include TVHeadend and VDR PVR. I personally use TVHeadend since it’s quite versatile. These can be installed via Addons -> Services I believe.

Since I’m using TVHeadend I need a client package so kodi can connect to my backend. Obviously I’m using TVHeadend Client since I’m using TVHeadend backend. The addons can be installed under Addons -> PVR Client.

VDR PVR might be easier to install and I’m not sure if it even requires a separate backend-client like TVHeadend does. I managed to dig out two guides one for VDR and one for tvheadend. I have not written or verified either of the two guides.

A step-by-step guide could be quite useful in the HowTos section if anybody feels like writing one.

Thank you! Really appreciate it

Default KIII DVB drivers are there, you don’t have to use CrazyCat.

1 Like

I have the TVHeadend 4.2 installed and running but when I try to connect through the web browser, the website won’t load at all… IP address and port is right “192.168.1.65:9981”, because I can connect through SAMBA. Also VNC doesn’t work. I also installed TVHeadend client and set it up the the K3 IP, and the addon won’t Enable. There’s some error. I’m sure it’s for the same reason why I can’t connect from my computer. I use the latest CoreELEC 8.95.0. Any advice please?

It does sound like TVH service is not running or some issue with it. But you say it’s running so you can see it somehow?

Strange if the client can’t connect since ultimately your box is connecting to itself. You have the IP correct in the client settings and you left the http(9981) and htsp(9982) port unchanged? (No username/password)

There shouldn’t be really much configuration that needs to be set. Even without the client or the DVB adapter visible you should be able to connect with HTTP to the port 9981 from your computer right after installing it as far as I can see.

If SAMBA wasn’t working and the client was it might be a firewall issue too. But just in case how is the firewall setting under Addons -> Coreelec configuration -> Network / Advances network settings? I have set it for Home but my network setup is simple with all the devices in the same subnet.

So, after trying everything, I decided to do factory reset and setup the CoreElec from scratch again… And it worked!!! I just don’t get it. I didn’t do anything differently… Just reinstalled it and it’s fine now. Thank you guys for all the help. Now I’m going to play with dvbs and dvbt channel… tuning etc… will be a long night :slight_smile:

Good to hear a fresh install worked for you.
If you upgraded from LibreELEC to CoreELEC this may have been the cause.
If you did a fresh install of CoreELEC and restored a previous LibreELEC BACKUP
to your CoreELEC OS that will also POSSIBLY caused the issues.
I had those issues and did a Fresh Install and a Fresh Build with no remnants of LibreELEC.

1 Like

For the benefit of those that have not migrated with us from the LE forums, it has long since been a pre-requisite of posting issues here that you first confirm the apparent issue still exists after a completely clean install of CE :wink:

The previous installation was actually brand new clean install of latest CoreElec, not migration from LibreElec or upgrade from older version. That’s why I was so confused, why it’s not working. But obviously something went wrong maybe when installing the generic LE drivers, maybe? Anyway, it’s ok now.

Hello,
I have an K3 Pro too.
I install : CoreELEC-S912.arm-8.95.0.img.gz
change dtb.img ( gxm_q201_3g_1gbit.dtb )
Boot on the Corelec
I use ethernet lan , go to add on install tvheadend addon
but after config ( ipdevice:9981 ) it don’t find dvb (if i understand include in the img )
My dmesg give no error but no dvb install

CoreELEC:~ # lsmod
Module Size Used by
8021q 19039 0
hci_uart 30134 1
dhd 752447 0
btsdio 4394 0
bluetooth 340354 4 btsdio,hci_uart
cfg80211 374882 1 dhd
6lowpan_iphc 10183 1 bluetooth
mali_kbase 379061 3
ir_lirc_codec 4996 0
lirc_dev 11232 1 ir_lirc_codec
ir_rc6_decoder 3423 0
wifi_dummy 806 0
ir_sanyo_decoder 2899 0
ir_sony_decoder 2417 0
ir_mce_kbd_decoder 4796 0
ir_jvc_decoder 2511 0
ir_rc5_decoder 2439 0
ir_nec_decoder 3367 0
meson_ir 4021 0
rc_core 17268 11 lirc_dev,meson_ir,ir_lirc_codec,ir_rc5_decoder,ir_nec_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_sanyo_decoder
amlvideodri 12066 1
videobuf_res 5322 1 amlvideodri
videobuf_core 16549 2 amlvideodri,videobuf_res
videodev 131761 2 amlvideodri
dwc_otg 233217 0
fbcon 38031 0
bitblit 4468 1 fbcon
softcursor 1168 1 bitblit
font 7327 1 fbcon

You have to install Addon / SERVICES / TVheadend SERVER 4.2
And then Addon / PVR clients / TVHeadend

Did you install both of these?

Hi, I think you are using the wrong DTB. To my understanding you should use gxm_q200_k3_pro with KIII Pro.

i don’t find in device_tree :
gxm_q200_k3_pro (and i have a q201 not q200 )
i try again ( gxm_q201_3g_1gbit.dtb - dtb.img ), restart
I install Tvheadend service install pvr client tvheadend
Go to add on
DRIVERS
choose Dvb drivers module
choose LE default drivers
Message “You have module drivers disabled, A system reboot is required to work properly.Would you like to reboot the system now”
Make reboot
Same : no dvb module, no tuner found in tvheadend
CoreELEC:~ # dmesg | grep dvb
CoreELEC:~ # dmesg | grep avl

if i put an usb dvb T2 astromeda , the device is see :slight_smile:[ 6.206055@7] usb 1-1.1: Product: dvbt2
[ 6.206068@7] usb 1-1.1: Manufacturer: astrometadvbt2
[ 34.598459@4] usb 1-1.1: dvb_usb_v2: found a ‘Astrometa DVB-T2’ in warm state
[ 34.676410@7] usb 1-1.1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 34.769648@4] input: MCE IR Keyboard/Mouse (dvb_usb_rtl28xxu) as /devices/virtual/input/input7
[ 34.775985@7] rc rc1: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 1
[ 34.776007@7] usb 1-1.1: dvb_usb_v2: schedule remote query interval to 400 msecs
[ 34.787324@7] usb 1-1.1: dvb_usb_v2: ‘Astrometa DVB-T2’ successfully initialized and connected
[ 34.787616@7] usbcore: registered new interface driver dvb_usb_rtl28xxu

But not the inside dvb t2 and dvb s2 …

oups make misteake : i find
gxm_q200_k3_pro.dtb change an retry …
Works better :
reELEC:~ # dmesg | grep dvb
[ 18.268221@6] DVB: aml_dvb_probe: probe amlogic dvb driver
[ 18.268261@6] DVB: aml_dvb_probe: dmx rst ctl = ffffffc0a04f1500
[ 18.268272@6] DVB: aml_dvb_probe: asyncfifo rst ctl = ffffffc0a04f1580
[ 18.268282@6] DVB: aml_dvb_probe: ahbarb0 rst ctl = ffffffc0a04f1600
[ 18.268294@6] DVB: aml_dvb_probe: uparsertop rst ctl = ffffffc0a04f1680
[ 18.268422@6] DVB: registering new adapter (amlogic-dvb)
[ 18.268430@6] DVB: aml_dvb_probe: Registered adpter: amlogic-dvb
[ 21.049544@7] amlogic-dvb dvb.51: DVB: registering adapter 0 frontend 0 (Availink avl6862)…
[ 37.670630@6] amlogic-dvb dvb.51: DVB: adapter 0 frontend 0 frequency 0 out of range (950000…862000000)