KM9 Pro Classic - Android 10 Factory ROM - Coreelec wont boot

After every Android update, for starting CE you have to use the same method you used for CE installation.
That is, if you had to press and hold reset button in AV port and then apply power, then release reset button when CE logo appears -> then you have to use that same method now for starting CE…

I am aware of this…
Thats the issue… No coreelec logo comes up after the toothpick method.
It Just hangs there.
Reboot without the SD card in goes into android just fine.

The only thing i can think of is with the new firmware might need a different DTB?

Create a new installation on different media, USB Drive, SD, doesn’t matter, and see if you can boot from that with the toothpick method.

Done that… Different SD card…
Same result.

None of the CE team have seen any Amlogic Android 10 device yet. So maybe something in the bootloader got changed and it wont boot anymore. Only a UART log will show the reason. Open the device and attach a UART adapter or take a look here: SDIO Debug Board

Or maybe the new firmware has a locked the bootloader. This happened to me on my Mecool KM8 box, and I had to revert and keep to original version…

Without a UART log of the device it’s just a look into the glass bowl…

Done that… Different SD card…
Same result.

Thanks. Probably a locked bootloader, but without logs or more information, we just as well can throw blindfolded darts at a board, hoping to hit bullseye.

Other than connecting an uart adapter any other way to find out?
Like i said Android 10 boots fine on emmc.

So without the SDIO Debug board there is no way of finding out if the bootloader is locked?

No, without UART there is no way to find out the reason why it’s not booting.
The SDIO debug board bring just a simple solution to get a UART without the need to open the device.

It’s up to you if and how you solve this issue. Maybe best is just to by a CoreELEC compatible piece of hardware. :wink:

android10-s905x2-boot-ce-hang2.txt (14.7 KB)
printenv-s905x2-ce.txt (10.2 KB)
hello , i have attached uart log. CE 9.2.5 , android 10 / s905x2 .
The screen hangs the logo and stops at the image attached .
I hope you can help us launch CE. Thank you in advance

Do have copied the correct dtb to COREELEC/dtb.img?

Of course I copied it :slight_smile: .

Hi, I report the same problem after upgrading to Android 10 in TV BOX Mecool KM9PRO. There is no functional downgrade to Android 9 :frowning:

Please anyone can test if last nightly 20210103 do boot now on Android 10? I fixed a environment issue but I am not sure if this is the reason on Android 10.

Which DTB did you use? Thanks.

Hi Portisch,
Tried the nightly on a fresh SD card using the s905x2_2g dtb.
Still the same.
Logo comes up for the TV Box and freezes.
its a KM9Pro Classic.
I think the issue is in the DTB image. If these havent been changed then i think it wont boot up.

I have found some info about DTB’s in Android 10.
Looks like the bootloader has changed, which is probably why its not working
https://source.android.com/devices/bootloader/dtb-images for more info.
Im not sure what is needed to get it working again… Can anyone shed any light?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice