KM9 Pro - Flashing screen on Samsung TV with HD Audio passthrough

Hi folks,
I have the latest Coreelec stable release running on KM9 Pro (s905x2, 4 gb, 32gb) from microSD. The box is directly connected to a Samsung NU6100 43 inch 4K HDR TV via Amazon basics HDMI 2.0 cable with ethernet rated for 18GB/s. The only issue I am facing with this setup is that when watching 4k HDR videos with HD audio tracks (TrueHD/DTS HD) the image on TV screen appears flashing as if backlight is flickering every other second. Its not a high frequency flicker. As soon as I change audio track to non HD audio this stops and I get normal and perfect HDR picture. This issue is consistently reproducible across various H.265 files which are 4K HDR and has at least one HD audio track. The moment I chose an HD audio track flickering starts. Anyone got any ideas why this may happen?

Important note - tested with non HDR 4k file with DTS Master HD audio and no issues. So it’s HDR + HD audio causing the issue

You can try in to change in System–>Video the force colour depth display to 10 bit.

Hi, if you meant the CoreElec options under System menu, I have tried to enable and disable all the below options one by one, reboot between the changes and then test.

  • Noise reduction
  • Forcing 8 bit video
  • Enable 4:2:2 colour sampling

But still no dice, same issue.

You did not upload any log and your settings are available only in EOL CE systems.
Update to CE-20 and check the options in display expert settings!

Oh! I thought enabling auto update in settings was supposed to get me to latest stable build automatically. Mine is something like 19.8. How do I update the CE20, do i need to re-image the microSD?

19.8 does not exist, use this guide:
https://wiki.coreelec.org/coreelec:devgeneric

I have Samsung TV similar to yours

Any success with clean install?.

Just a thought
You are connected directly to TV
For Audio you are limited to 2 channels
Internal speakers Samsung

HD Audio multichannel…
Still TV speakers are stereo
2.0 channels

In Samsung TV settings go to
Settings
Sound
Expert Settings
HDMI Input Audio Format

Change from Bitstream to PCM

Maybe will help

Happy Testing