Kodi aborting playback

Hi Coreelec Team,
The below started happening a few days ago after I moved my media from a Mac Mini to a Synology DS920+ NAS. I run Coreelec 19.3 Matrix on an Odroid N2+.

I also run Corelec 9.2.6 (Leia 18.9) on another device and the issue does not occur. This leads me to believe it is an issue with Kodi Matrix. I found a similar issue here that describes my issue exactly (albeit on Kodi for Andoid TV). It might be of some help.

Issue Description

  • After a few minutes of playback the video will just quit.
  • I use Plex as my media server on my NAS and plexkodiconnect (pkc) addon with direct path enabled in Kodi (pkc just tells kodi what to play and the rest is up to kodi).
  • I logged the issue with the pkc developer here and he advised that it is an issue with Kodi Matrix (see log snippet below).
  • You can find the results of his investigation there as well as my full log.
  • It wouldn’t let me upload here (I got the error “new users cannot attach files”) and I didn’t want to upload direct from Coreelec because I needed to delete a plex token first.

What I have tried so far

  • Complete wipe and reinstall of Coreelec 19.3 Matrix (estuary skin and only pkc addon installed)
  • Complete wipe and reinstall of Coreelec 19.2 Matrix ((estuary skin and only pkc addon installed)

At this stage I don’t really know what else to try so would really appreciate any help you can give.

Log snippet

ERROR : Read - Error( -4, read call failed with “Command was cancelled” )

After a few hours of googling I came across a similar issue. It was fixed by disabling CEC. I did that and played 3 movies without any playback aborted. I turned it back on and it happened again. I have no idea how they could be related.
Can anyone shed any light on it?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice