Kodi IPTV Simple Client..At wit's end

Hello all,

I took the leap and joined the forum to make this post. I have looked and searched all I could but haven’t found any solution to my issue…I am truly at my wit’s end and pulling my hair as we speak :slight_smile:

Setup I have:
Minix-u9-h, running Coreelec 9.0.1 on an exernal SSD (didn’t make the decision to put it on the internal eMMC just yet as I wanted to be able to reboot into the box’s original firmware if anything went wrong)

So, I did a clean instal of Coreelec (with the correct dtb from the device tree) and had no issues, mostly thanks to all the great how-to’s on this forum.
I had no issues what so ever and was using the PVR IPTV Simple Client, when it just stopped working.

Couldn’t fix it so I took my SSD and did a whole new installation of Coreelec on it and went back to my minix. Set up the IPTV Simple Client and it won’t work.
It loads my channels list (local file), PVR service is running as far as I can see in the Coreelec settings menu, but when I press play on any channel nothing happens. It just won’t load.
I might have to add that I also have setup a EPG (remote path) and when booting into Kodi it loads the channels, then tries to load the EPG (it stays at 0%) and stops.
There does not seem to be any issue with my connection, because if I reboot onto the eMMC and into the minix firmware I can go into TV and select any channel, view the whole EPG. The settings of IPTV simple client are the exact same in both (the simple client on the minix firmware/android is 3.5.7).

I really can’t get to grasp with this. To summarize:
Simple Client was working on Coreelec without issues.
It stopped working. Two clean installs later I still can’t get it to work
On minix firmware and Android version it does work (same local channel list and remote epg settings as in Coreelec)

I hope my problem is somewhat clear and I would really love some help as to troubleshoot this and find out what is wrong or causing this issue in Coreelec.
Any help would be much appreciated and thanks in advance for reading my ramblings

p.s. I have tried to get a log within Coreelec, but I don’t seem to be able to find the logs or even if any are made. Maybe I need to extract the logs through a ssh connection?

Ok, I’m back…Little update. After pulling out all my nosehairs one by one with a tweezer, i think I found the issue and was able to solve it.

After reading the log files (enabled component specific logging -> PVR) and found the following error
ERROR: CCurlFile::Open failed with code 0 for (insert url here)
Apparently this means Kodi cannot open the URL. Specifically it looked like it cannot resolve the domain name.
The solution to this was given on the Kodi forum: add the adress to the hosts file.
And sure enough, after adding the domain to the hosts.conf and rebooting once more it started working again.

Now, what I don’t understand is how it would go from working fine one day, to not working the next in the first place.
So just came here to add to my own question, maybe some day this might help someone out who’s having the same issue.

greetings

OUCH!! :scream:

It seems, you have a general problem with name resolution on your device.
Does this box use dhcp to configure its network?
What are the contents of /etc/resolv.conf
Does a simple ping domainname works on this box?

Hello and thanks for getting back to me. So, after the initial enthousiasm I am back to square one…one step forward, two steps back huh?

Anyway, after yesterday’s “solution” it went all down the drain as soon as I changed a channel and since then I can’t get the simple client to work again (just to be sure; if I go back to the minix firmware/android with kodi I can get it, no problems there)

To answer your questions:

  • yes the box uses dhcp (but I have a fixed internal IP for the box anyway, so put it in manually for testing purposes -> no difference)
  • The content of the /etc/resolv.conf
  • /etc/host.conf
  • a simple ping domainname to the url in question does not work, 100% packetloss. I can do pings to other domains without a problem

Do you have any idea why this became a problem overnight? I have been using Coreelec for a couple of months now without a problem and then all of a sudden this? Also, I can’t understand why this isn’t a problem when I use Kodi (also Leia) through the minix firmware/android.
And to conclude; it worked yesterday uninterupted for hours, until I changed the channel I was watching.
Can’t find the consistency in this problem…but that is 100% me :slight_smile:
Thanks again for reaching out and I hope you (or anyone else) can point me in a direction to further troubleshoot this.

Could you please again try to ping the domain of your IPTV provider while this problem occurs?
Even if you don’t receive a reply, it would be great to know, if your device is able to resolve the domain to an ip address.

I can’t think of any recent change in CE, which could have caused this issue.
If this was a general problem, a lot more users would have reported it.

Maybe you could try an older version of the simple iptv client.
Could you also check the version of this client in Android (older/newer)?

Hello,

The domainname does resolve to an IP adress.
My minix u9-h runs on latest firmware (FW008) and Android 6.0 (it doesn’t look like they are ever upgrading to Nougat, tough titty I guess)
The simple IPTV client running on that is 3.5.7
In Coreelec (9.0.1) it’s simple IPTV client 3.5.7.3

Now, guess what?! It is working again :confused: I had some sort of brainfart and noticed one difference in all these ordeals. As I said I have Coreelec on a separate SDD. This means when I manually reboot the box I have to hold the on button and so on…Now I noticed that sometimes while rebooting it will flash the Minix splash screen for just a second before showing the Coreelec logo.
Just a few minutes ago I rebooted again manually (to see which version of Simple IPTV is running on Coreelec) and I held the on button all the way until I saw the Coreelec logo. This time it didn’t show the minix/android splashscreen prior ro the Coreelec logo, and guess what. Channels are working, and even after zapping like a maniac through various channels it is still working.

Again, this might be a brainfart, I have been accused of that before, but could this be even remotely the cause of issues?
Have a great day and please don’t feel obliged to answer my ramblings. I appreciate it a lot, but I could also understand if you just have the impression this is leading nowhere. Your help so far has helped tons and for that I am already grateful.

I don’t own any Minix device and honestly have no idea how it behaves while pressing the on button and booting from different devices.

But your problem is still a bit strange.
It indeed looks like your U9-H is having networking problems, because name resolution completely fails.
Excuse me, if you already answered this question: Do you use wifi or ethernet to connect it to your network?
If it is the former, maybe it’s dropping the whole wifi connection while this issue occurs.
Ping to local ressources using the IP address would also fail then.

Hey, nah do everything wired besides my pad and phones. Anyway, it stopped working again. I’m starting to think there is some issue with Simple client, the latest version of coreelec and my setup. As we speak I am watching tv through the minix android software and simple client without any issue.
Just don’t like the whole android thing on the box and prefered coreelec for it’s swiftness and image quality. So, I give up for now. Am going to try Libreelec and see if I run into the same problem, and just wait it out until there is a coreelec update and try that one again.

Last thing, if you don’t mind? I can only access pvr addons through the coreelec repo. The thing is, even when it’s installed if I go to the simple client settings and select update it will show me an update option (which in fact is the exact same version as is already installed).
Thanks once more for taking your time answering me and have a great day.

I really don’t think the iptv client is the problem here, because you didn’t even get name resolution on the ssh console. Also scratch my idea about the whole network not being available. You wouldn’t even be able to connect to your box using ssh in this case.
It really sounds like a problem with your iptv provider, but then it wouldn’t work in Android.

You could try the latest nightly release (I assume, you are using the stable 9.0.1 release at the moment).
It is by far newer and also includes a nightly addons repo, where at least the previous iptv simple client 3.5.7.2 is available additionally to the newest one.

I want to come back to this issue. As it is not moving anywhere and it is a weird problem.
For weeks this issue is bothering some people.
If I do a search on Google you’ll find people telling the same story as described above in the other messages
Also a couple at kodi forums. The ones with the problems are all running CoreELEC.
I am not saying it is definitely CoreELEC but the ones having this issues are running CoreELEC.

I myself have checked as well with different kodi’s installs.
LibreElec and Android Kodi versions have no problem with the same Simple IPTV client version.
Also my LG tv with IPtv app is playing the IPTV streams without any issues on WebOS.
That makes it save to say it not the IPTV provider as it works at all other platforms than CoreELEC.

What the weird thing is and this is what others describe as well is that if I use any other app for just opening the stream and close it after 1 sec. All works well with Simple IPTV client for let’s say 20minutes. It is as if it is a dns problem but it is not because I can ping the url from my CoreELEC box and it resolves it to the IP address.

I tried the nightly builds as well but here also the same problem.
What I still want to test is an older version of Simple IPTV client on a old install of CoreELEC

I noticed the following error in my logs:

2019-05-09 00:08:17.981 T:4092048160 NOTICE: VideoPlayer: waiting for threads to exit
2019-05-09 00:08:41.788 T:3206026096 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
2019-05-09 00:08:41.788 T:3206026096 ERROR: CCurlFile::Open failed with code 0 for http://tv.meerzenders.hitv.one:80/live/nrt333/66778/12525.ts:
2019-05-09 00:09:11.791 T:3206026096 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
2019-05-09 00:09:11.791 T:3206026096 ERROR: CCurlFile::Open failed with code 0 for http://tv.meerzenders.hitv.one:80/live/nrt333/66778/12525.ts:
2019-05-09 00:09:11.792 T:3206026096 ERROR: Open - failed to open source http://tv.meerzenders.hitv.one:80/live/nrt333/66778/12525.ts
2019-05-09 00:09:11.793 T:3206026096 ERROR: CVideoPlayer::OpenInputStream - error opening [pvr://channels/tv/All channels/pvr.iptvsimple_701500424.pvr]

I changed the password and user in the above part of the log stream url so the stream will not play. I rather hide the login details. Otherwise I could post a link to the whole log. I am willing to do so if this is needed to fix the problem.

I registered in the forum to reply to this issue since I also pulled all my nosehairs one by one for this one.
I thought I was the only one with this issue.

I had to learn how to use tcpdump. Then comparing the tcp headers between Coreelec and pc connection to my IPTV provider, I finally found some difference that revealed itself to be the cause of the issue.
In my case the issue started long ago after a Coreelec update back in June/July last year.
This command is working for me. Try it in ssh and if it works put it in autostart:
echo 2 > /proc/sys/net/ipv4/tcp_ecn

My autostart looks like this:
(
echo 2 > /proc/sys/net/ipv4/tcp_ecn
) &

1 Like

Thank you for answering my question.
You are amazing finding this fix. It is working again, I am so happy :wink:
While you were pulling your nose hairs out, I did the same with the hair on my head.
Great fix/workaround but what is causing it you think, different kernel or something?

Thx

interesting. I checked LE 9.0.1 on Rpi2 out of curiosity, and it has ecp_ecn also on 1…

I am glad to know that it worked for you too.
Not sure you pulled more hairs than I did. :wink:
For me the issue started with version 8.90.5 and only a few months ago I finally found the cause and this solution.
I think that value in /proc/sys/net/ipv4/tcp_ecn may have changed at some point, but have no idea why, and also why others experienced the issue at a later version.

Maybe the Devs can clarify and eventually change the default value to “2” if there are no other implications.

@Under: Could you tell me, where to finde the autostart.sh? I created one and copied it to /storage/.config/ but after reboot, the value of tcp_ecn is still 1.

EDIT: Okay I found it.

Created the autostart.sh with nano and edited it. Now after reboot the value is 2 :slight_smile: