Kodi with Ambilight -> leds stay off

hello together

for a long time i had a windows 10 computer with kodi and ambilight. now i switched to an odroid n2. thanks for the cool CoreElec, runs very quietly :slight_smile: unfortunately i haven’t got ambilight running yet.

my setup:
odroid n2+
arduino with adalight(WS2801)

CoreElec 9.2.4
Hyperion.NG 9.2.104
Your Hyperion version: 2.0.0-alpha.7

via ssh I see that the arduino is connected to port 3:

Bus 001 Device 003: ID 2341:0043 Arduino SA Uno R3 (CDC ACM)

In the attachment I post the Hyperion settings.

About System-> Log ( set to debug ) I see unfortunately no log. where is that stored?

thanks for your help and have a nice sunday :slight_smile:

Your sure your tty device is correct?
2.0.0.alpha is able to auto connect the UART. Just enter auto as device and try again after a reboot.

the port should be the right one. i’m just not sure if it’s right with: /dev/tty03? i tried it with /dev/ttyUSB03 but they still don’t work.
I am a linux beginner.

i just checked all settings, but can’t find the automatic connection. where is the option hidden?

thanks for your help :slight_smile:

Just insert auto instead of /dev/... as device.
When you changed the debug level in Hyperion Webinterface and rebooted once the log should be come available.

with: auto the LEDs now light up twice on restart. this was not the case before. even if i now switch the service off and on again via web conf, the LEDs light up briefly in the rgb color. the path should be correct now but the LEDs are still off :frowning:

unfortunately i don’t see anything in my log. i saved it on debug and restarted the odroid but it is still there: No log messages available. is there a way to access the log via ftp?

journalctl -o short-precise --since "2 hour ago" > /storage/backup/hyperion.log

Also check your baudrate if it match the one from your Arduino. As example I use 115200.

I can’t tell you what I’ve changed now, but the leds work!

I have checked and changed the baudrate of arduino before.

thanks for your time and your help :slight_smile: now i am happy :smiley: